Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It takes more than a minute for Ubuntu to boot up on my new laptop. I have Windows 7 and Ubuntu 12.10 installed using Wubi.

From dmesg, I see the following:

[    2.934384] EXT3-fs (loop0): recovery required on readonly filesystem
[    2.934387] EXT3-fs (loop0): write access will be enabled during recovery
[   23.804784] kjournald starting.  Commit interval 5 seconds
[   23.871524] EXT3-fs (loop0): recovery complete
[   23.871526] EXT3-fs (loop0): mounted filesystem with ordered data mode
[   45.069369] Adding 262140k swap on /host/ubuntu/disks/swap.disk.  Priority:-1 extents:1 across:262140k 

Note the big time gap between the entries. You might ask whether I put my computer to a unclean shutdown because of the filesystem recovery, but I just shut it down gracefully using the system menu.

How can I improve the boot time?

share|improve this question
1  
Describe how you are shutting the system down. If you are not going through a clean shutdown, you will get disk cleanup on boot. –  ubfan1 Dec 29 '12 at 17:20
    
loop0 device? Are you using Wubi? At least this is not a regular hard disk installation. –  gertvdijk Dec 29 '12 at 17:29
    
I use Settings->Shut down...I normally close all the applications before shutting down my system but not always.But this happens everytime I boot.What is it that I must ideally do ? –  Pal Dec 29 '12 at 17:29
    
Yes,I used Wubi installer to get Ubuntu on my windows 7. –  Pal Dec 29 '12 at 17:30
2  
wubi is slower as it operates in virtual environment. –  Web-E Dec 29 '12 at 17:36

1 Answer 1

That's not normal for Wubi. Mine takes about 4 seconds to load where yours is taking 20.

The key is that your filesystem is marked as corrupted. And if it's doing that every time then whatever fsck is doing is not fixing the problem. So you could fsck it from a live CD and see if it provides any decent output. Or try running chkdsk /f from Windows - as there could be some NTFS corruption as well. Or try reinstalling.

Here's my output for the equivalent operations - and ignore the swap as it uses a partition (also my root.disk is ext4 as it was installed via the ISO but that shouldn't make any difference to the time required to mount it):

[    2.113178] usb 1-1.5: USB disconnect, device number 5
[    4.450760] EXT4-fs (loop0): mounted filesystem with ordered data mode. Opts: (null)
[    7.650487] Adding 4300796k swap on /dev/sda7.  Priority:-1 extents:1 across:4300796k 
[    8.583207] EXT4-fs (loop0): re-mounted. Opts: errors=remount-ro
[    9.025386] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.