Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Why does my computer get less battery life with Ubuntu compared to Windows?

I am running Ubuntu 10.10 on my Dell Studio XPS 1640 and have about one hour of battery life in it, compared to about 2.5 hours running on Windows 7.

This is with wireless and bluetooth on, but still, the difference seems incredible.

What could be causing such a difference and is there a way to close the gap without losing core functionality?

EDIT: here's some output from powertop. This is with bluetooth turned off and Wifi turned on. The output seems pretty normal to me, but as indicated, this is about 1 hour of battery life on a full battery...

Wakeups-from-idle per second : 476.2    interval: 10.0s
Power usage (ACPI estimate): 2.5W (1.2 hours)

Top causes for wakeups:
  30.0% (167.2)D  chrome
  21.0% (117.3)   [extra timer interrupt]
  13.9% ( 77.4)   [kernel scheduler] Load balancing tick
   3.4% ( 18.9)D  xchat
   7.1% ( 39.8)   [iwlagn] <interrupt>
   5.9% ( 32.9)   AptanaStudio3
   3.9% ( 21.6)D  java
   2.7% ( 14.9)   [TLB shootdowns] <kernel IPI>
   2.5% ( 14.1)   docky
   1.8% ( 10.0)   nautilus
   1.6% (  9.0)   thunderbird-bin
   1.0% (  5.5)   [ahci] <interrupt>
   0.9% (  5.0)   syndaemon
   0.8% (  4.3)   [kernel core] hrtimer_start (tick_sched_timer)

EDIT: after changing /proc/sys/vm/laptop_mode to 5 (it was set to 0), wakeups seem to have decreased, although usage still seems far too high:

Wakeups-from-idle per second : 263.8    interval: 10.0s
Power usage (ACPI estimate): 2.6W (0.9 hours)

EDIT: I seem to have discovered the main cause: I was using the open source ATI Drivers. I recently installed the official ATI drivers and laptop battery life seems to have doubled since.

EDIT: last edit. The previous 'solution' of installing the official ATI drivers turns out to be a non-solution. Although it does increase battery life, my laptop resolution is maxed out at 1200x800 after a reboot. (Please note that this problem does not need answering in this question as it is a seperate case)

EDIT & SOLUTION:

After more trial and error I finally found a custom PPA that patches Maverick's 2.6.35 kernel. My wakeups have now decreased from 450-1100 to a maximum of 120 (!).

Wakeups-from-idle per second : 110,2    interval: 15,0s
Power usage (ACPI estimate): 2,7W (0,7 hours)

Top causes for wakeups:
  19,2% ( 25,7)   [extra timer interrupt]
  17,0% ( 22,7)   java
  13,9% ( 18,6)   [kernel scheduler] Load balancing tick
  10,5% ( 14,0)   docky
   8,8% ( 11,7)   [iwlagn] <interrupt>
   7,5% ( 10,0)   nautilus
   4,3% (  5,7)   [kernel core] hrtimer_start (tick_sched_timer)
   3,7% (  5,0)   syndaemon
   3,0% (  4,1)   [ahci] <interrupt>
   3,0% (  4,1)   ksoftirqd/1
   0,1% (  0,2)D  flush-8:0
   1,6% (  2,2)   mysqld
   1,2% (  1,7)   python
   0,7% (  1,0)   [kernel core] iwl_bg_monitor_recover (iwl_bg_monitor_recover)
share|improve this question
    
Have you upgraded to Natty? Seems like this bug is back, and I haven't been able to find a fix yet –  bruno077 Apr 29 '11 at 18:06
    
@bruno I upgraded and am having problems again :( about 1200 wakeups per second, which is not good, obviously. –  Aron Rotteveel Apr 30 '11 at 4:48
add comment

marked as duplicate by Eliah Kagan, Jorge Castro, fabricator4, Stephen Myall, hhlp Jan 11 '13 at 10:47

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

4 Answers

up vote 3 down vote accepted

The Ubuntu Power Management Wiki says a system should be waking up about 40 times per second. Yours is 476!

That said, here is my output:

Wakeups-from-idle per second : 185.4    interval: 1.8s
Power usage (ACPI estimate): 5.8W (8.9 hours) (long term: 6.4W,/8.1h)

Top causes for wakeups:
  37.5% (137.0)   [kernel scheduler] Load balancing tick
  19.2% ( 70.0)   chromium-browse
  10.4% ( 38.0)   [uhci_hcd:usb5, eth1] <interrupt>
   8.2% ( 30.0)   [kernel core] hrtimer_start (tick_sched_timer)
   7.7% ( 28.0)   [kernel core] add_timer (wl_timer)
   4.9% ( 18.0)   xbindkeys
   4.4% ( 16.0)   [i915@pci:0000:00:02.0] <interrupt>
   2.5% (  9.0)   Xorg
   1.9% (  7.0)   PS/2 keyboard/mouse/touchpad interrupt
   1.1% (  4.0)   [Rescheduling interrupts] <kernel IPI>
   0.5% (  2.0)   gvfs-afc-volume
   0.5% (  2.0)   gnome-terminal

What I find interesting:

  • my wakeups are 185, which is much lower than your 476, but higher than the 40 target
  • your reported power usage is only 2.5W - that sounds suspiciously low
  • I'm getting 8.9 hours of battery life, which is about what it should be

First obvious thing to try. Run this from a bash prompt:

cat /proc/sys/vm/laptop_mode

It should print 5.

After that, maybe others have some ideas, or read the Wiki to see if that helps.

share|improve this answer
    
Thanks for the insighfull reply. I executed cat /proc/sys/vm/laptop_mode and it returns 0. Changed it to 5 now and will see what happens. –  Aron Rotteveel Jan 28 '11 at 8:00
1  
BTW it should be 5 only when adapter is disconnected. –  Owais Lone Jan 28 '11 at 9:29
    
Q: Wouldn't /proc/sys/vm/laptop_mode get overwritten automatically upon a reboot or change in battery state? If yes, what would be a permanent solution. –  Owais Lone Jan 28 '11 at 9:30
add comment

use powertop and see where the power goes

share|improve this answer
add comment

powertop is awesome tool, and if you have intel hardware check this out http://www.lesswatts.org http://www.lesswatts.org/projects/powertop/known.php

share|improve this answer
add comment

It sounds like your laptop's ACPI support is poor. this happens when the laptop manufacturer doesn't document all the quirks in the power saving features. The outcome is that Ubuntu can not make parts of the laptop go to sleep, and worse the cores can't be switched off when not required.

What I think you should do is switch off bluetooth, see how that effects the battery and the load. Then turn off wifi and see if that effects it. Check your bios settings for compatibility ACPI support and see if you have anything running which is constantly checking the disk.

Also check to see what brightness your screen is set to, lots of energy burns away with the screen.

share|improve this answer
    
Thanks for the tips. I actually tried disabling Bluetooth, Wifi and set my brightness to near-minimum, but I don't seem to get more than 1 hour of battery life on a full battery. –  Aron Rotteveel Jan 27 '11 at 9:03
2  
Then it's probably Dell who need to fix the issue in the kernel ACPI support. They've obviously done something weird. Lets hope a future version of Ubuntu can fix the issue, but I don't know. –  Martin Owens -doctormo- Jan 27 '11 at 15:51
    
Yeah, could be that. The fact it only reports 2.5 watts of power being used suggests it's not getting/reporting the right info. –  Mikel Jan 27 '11 at 23:35
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.