Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've tried multiple ways to solve my problem as described in other topics in this forum, but none succeeded. The Headphones sound worked when I first installed Ubuntu 12.10, but after a few updates it ceased to function. Sound works fine with the speakers but as soon as I insert the jack, there is nothing but silence. I've checked Alsamixer and when I insert the jack it mutes the speakers but not the Headphones column. I've even tried installing the drivers from Realtek but it was a very bad idea since it crashed my OS completely and I had to re-install everything. I'm a bit on the newbie in this Ubuntu thing in case you haven't noticed ;) Anyway I would really appreciate some help here since I have a small baby and she sleeps a lot so I can't disturb her with the sound coming from the speakers. I have a Toshiba Satellite P200-1IE and Ubunto 12.10. Thanks in advance

share|improve this question
    
Please post the contents of /var/lib/alsa/asound.state –  Richard Ayotte Dec 29 '12 at 15:49
    
Ok, here it is: ubuntuone.com/3EwMdk6AdMcfwOFBieo2yo –  Tiago Santos Dec 29 '12 at 19:38
    
Try setting the Front Headphone Jack to true with alsamixer. –  Richard Ayotte Dec 29 '12 at 23:37
    
Ok, I edited the above mentioned file, and set the value beneath Front Headphone Jack to true... but without sucess... still no sound from the headphones... –  Tiago Santos Dec 30 '12 at 1:18
add comment

4 Answers 4

I had the same problem and this fixed it for me:

  1. Download the basic run.py script to your preferred download folder by following the instructions on http://www.alsa-project.org/main/index.php/HDA_Analyzer i.e. run the following command in a terminal wget -O run.py http://www.alsa-project.org/hda-analyzer.py
  2. Check that the permissions of run.py are set to root by using sudo chown root:root /<download location>/run.py
  3. In a terminal change run.py to an executable file using sudo chmod +x /<download location>/run.py
  4. Run the script in a terminal sudo python run.py
  5. In the left-hand sidebar select Node[0x15] PIN
  6. Check the box next to EAPD
  7. Click Exp then save as 'snd_hda_codec_diff.py' in /etc
  8. Add "python /etc/snd_hda_codec_diff.py" without the quotes to the file /etc/rc.local just above the line "exit 0" with your favourite editor

After the next reboot your headphones should work. Hope this helps.

share|improve this answer
add comment
  1. Open a terminal.
  2. Run alsamixer (type the command and hit Enter)
  3. Press F6 then just disable the automute button.

Please make sure that you have your headphone jack inserted while doing all this.

share|improve this answer
    
Disabling auto-mute turns on the sound on the normal speakers not on the headphones. –  Calmarius Oct 5 '13 at 14:34
add comment

In this file: /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf

Comment those line as shown:
[Jack Front Headphone]
#required-any = any

[Jack Headphone]
#required-any = any

Restart PulseAudio without root: pulseaudio -k

share|improve this answer
    
It didn't work for me. i m using toshiba sattelite.Do I need to restart system after this change? –  sudmong Jan 26 '13 at 19:32
    
Doesn't work, even screws up normal speaker output: sound doesn't return after headphones removed. –  Calmarius Oct 5 '13 at 14:33
add comment

I had the same issue (same computer / same problem). I resolved it by installing the lastest drivers from alsa-project:

wget ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.25.tar.bz2
tar -jxf alsa-driver-1.0.25.tar.bz2
cd alsa-driver-1.0.25/
./configure --with-cards=hda-intel --with-oss=yes
make
sudo make install

restart your computer and enjoy.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.