Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had a battery problem on my Dell Inspiron N5010 I used powertop and I found out that my touchpad driver has most of wakeups and consumes battery

I had this from powertop

Wakeups-from-idle per second : 296.2  interval: 60.0s

Power usage (ACPI estimate): 2.2W (11.7 hours)

Top causes for wakeups:

24.9% (106.5) PS/2 keyboard/mouse/touchpad interrupt

15.1% ( 64.6) [radeon]

11.0% ( 47.2) [iwlwifi]

3.8% ( 16.4) [Rescheduling interrupts]

3.4% ( 14.4) chrome

3.0% ( 13.0) swapper/1

2.4% ( 10.2) swapper/0

2.4% ( 10.2) Chrome_IOThrear

share|improve this question
    
I found a person that said we write a value about 50 in the file /sys/module/psmouse/parameters/rate and the pointer will be a little slower but it will help but i coudn't edit this file even on root user –  Mhd Tareq Shaheen Dec 29 '12 at 19:24
    
If I'm misunderstanding this then please correct me but on a laptop, shouldn't your touchpad be the main cause of wakeups for EVERYONE. Basically every time you touch your touchpad and it makes your computer screen light up, that's a wakeup. If this program is measuring these then you're basically trying to prevent yourself from using your touch pad. In which case, most computer manufacturers allow you to disable the touchpad by pressing a key combination on your keyboard. –  KI4JGT Dec 29 '12 at 19:31
    
You can always edit your own question to provide additional information - no need for comments here. –  guntbert Jan 23 '13 at 19:53
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.