Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Xubuntu system:

$ uname -a
Linux tnick-desktop 3.5.0-21-generic #32-Ubuntu SMP Tue Dec 11 18:51:59 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
$ lsb_release -a
Distributor ID:  Ubuntu
Description:     Ubuntu 12.10
Release:         12.10
Codename:        quantal

with an Nvidia video card:

$ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation G96 [GeForce 9500 GT] (rev a1)

When I first installed Xubuntu and Nvidia's current driver all went fine. I was able to use nvidia-settings to configure the monitors to show a side-by-side view, saved the xorg.conf file and everything worked fine.

Some days ago I was curious about Settings Manager > Display section. I went looking, did not change anything and that was that. However, ever since, when I restart the system the layout that is saved in xorg.comf is not applied, so each and every time I have to use nvidia-settings, lay them out side by side and apply this. I tried using

sudo nvidia-settings

but that made no difference (not that I was expecting it to, but it was suggested in a question here).

I also tried

un-install - restart - install - restart - nvidia-settings, lay them out - restart

but that gave me black screens after Xubuntu logo, then, on third attempt, went back to same view on both displays.

The content of the xorg.conf file does not change between sessions:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 304.51  (buildd@batsu)  Fri Oct 12 12:53:54 UTC 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LG Electronics L1942"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9500 GT"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "CRT: nvidia-auto-select +1920+0, DFP: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24

I tried to install Nvidia binary X.Org driver (version 173) but ended up in an error pretty soon:

The following packages have unmet dependencies:

nvidia-173: Depends: x11-common (>= 1:7.0.0) but 1:7.7+1ubuntu4 is to
be installed
            Depends: xorg-video-abi-12 but it is not going to be installed
            Depends: xserver-xorg-core (>= 2: but 2:1.13.0-0ubuntu6.1 is to be installed

with an Crash report detected message.

Apart from reinstalling the system, what else should I try?

share|improve this question
up vote 5 down vote accepted

As far as I understand, the way Ubuntu reads xorg.conf has changed in recent releases. What worked for me was to put a "good" xorg.conf file into


and reboot or log out and back in.

I still haven't figured it out entirely, but I believe that upon startup, Ubuntu looks there for any X setting overrides. Having an entire xorg.conf file there is probably not the idea, but it worked for me.

I believe that the problem is, that the settings managers from Nvidia or Ati save their changes to /etc/xorg.conf but Ubuntu does not update any of its own files dynamically... something like that.

Sorry if this is not a scientifically correct solution, but I believe it could be a work-around or at least give you some pointers for further investigation.


share|improve this answer
DrTebi, thank you for your answer. Indeed, it has solved my problem (if is a hack or not is not a concern for me). Also, thank you for registering an account just for responding to my question. :) – TNick Dec 29 '12 at 17:28
Important note for Xfce-users: make sure to delete ~/.config/xfce4/xfconf/xfce-perchannel-xml/displays.xml if it is present, as this overwrites the xorg.conf settings but is itself not working correctly (at least for me with Xubuntu 12.04). – luator Aug 18 '15 at 7:20

FYI, I was having this problem with Xubuntu 12.04, and none of the fixes for Nvidia Xserver did the trick. I ensured I ran nvidia-settings as root, regenerated xorg.conf, changed the xinit files, edited xorg.conf manually (using "TwinViewOrientation" in every imaginable way, as well as playing with the offsets). I reinstalled the driver twice (and somehow managed to lock my user account out in the process?) and re did all of the aformentioned fixes. I pretty much tried everything I could find by searching for problems with Nvidia Xserver dual monitor and persistent settings.

In the end, moderately hungover me approached the problem from a different angle: I just searched for other ways to use dual monitors in Xubuntu. "How to use multiple monitors in Xubuntu" did the trick for me. Basically I installed what it said and generated the script for use in startup applications, completely side-stepping the nvidia-settings and xorg.conf trouble.

share|improve this answer
Thank you for your input. I'm not really a man of faith but on this matter I prefer a cautioned approach: I won't touch it before it's broken again, :)) I'm sure your answer will help some frustrated soul out there... – TNick Feb 25 '13 at 6:14
Welcome to Ask Ubuntu! Please avoid posting the same answer in more than one place. When tempted to do so, this typically means: (1) the answer should be customized to account for what is different about the different questions, (2) one question should be flagged for closure as a duplicate of another question (you can flag posts with 15 reputation), (3) the answer should really be a comment, or (4) the answer should be posted in the most appropriate place, and one-line comments posted on the other questions summarizing and linking to it. – Eliah Kagan Feb 25 '13 at 11:09
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – RolandiXor Feb 25 '13 at 23:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.