Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu server 10.04 and it comes with its own couchdb version 0.10 I am trying to upgrade this to 1.0.1 or at least install 1.0.1 on the side. No matter what I try, I can't seem to be able to do it. Things I have tried are below:

  • sudo apt-get install couchdb (installs something, but when I use curl to check on it, it gives me the Welcome JSON with a version number 0.10)
  • sudo apt-get upgrade couchdb (installs a whole bunch of stuff, same result)
  • sudo apt-get remove couchdb (somehow still running - also purged. now, I can curl to http://127.0.0.1:5984 and get the welcome JSON, but couchdb is not installed any more i.e. typing in couchdb stop gives me a "not installed" error)
  • Installed from the 1.0.1 binary, but after installation, it is not actually running - tested with netstat)
  • Tried to change the port number in the local.ini file and tried to restart, but now can't figure out how to restart couchdb1.0.1 or even if it is actually running.

In case I haven't made it abundantly clear, I am completely new to linux. I have some rudimentary experience with .htaccess and configuring Apache and PHP but that's it. If you can help me, I will be very grateful!

share|improve this question
    
I've finally got it to work, as an FYI to anyone else stuck after installing via the .bin: you need to go and modify permissions on the installation folders to use the couchdb user. I changed the port number to avoid conflicting with the 0.10 version. –  electrichead Jan 26 '11 at 18:06
    
I think I should add - it's taken me most of the day to find this, but you also need to change permissions on the .delete folder in install_dir/var/lib/couchdb to allow the couchdb user to write to it. Otherwise, you will not be able to delete. –  electrichead Jan 26 '11 at 22:38
    
You should rewrite these comments into a second answer below :) –  Chipaca Jan 27 '11 at 14:57
    
I'm having similar problems. I'm running ubuntu 11.10 on my laptop, but I ran into the same errors and problems. I'm reading your comments, but it's still slightly unclear to me how to resolve this... –  Costa Feb 27 '12 at 20:06
    
Sorry @Costa, I didn't read your comment until recently. I won't be of much help as I abandoned this early last year. I do remember having it working, but other than the comments above, I don't remember much. For couchdb, I am currently favouring heroku and not using my own server at all. From what I can remember, it was to do with permissions on the folders where you install couchdb. There is a couchdb user and this user needs to have permissions to the install directories, and special permissions to the .delete directory in the location above. –  electrichead Mar 8 '12 at 19:28

1 Answer 1

up vote 2 down vote accepted

May I suggest you use our stable ppa? CouchDB from there will be landing in 10.04 backports soon.

share|improve this answer
    
Thank you, I did come across your posts from other threads. It was next on my list, but I seem to have fixed my problems. I have no doubt it is probably a much simpler solution to the one I followed. –  electrichead Jan 26 '11 at 18:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.