Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Have a 750 gig external HDD. Have format it in Ubuntu 12.10 using FAT32 since I have to switch between windows, linux and osX. Used quick format option when doing this. Have named drive but Ubuntu doesn't give drive letter. Tried loading on windows 7 and drive comes up under manager as unallocated. Any suggestions about how what I did wrong and how to fix this problem? Thanks.

JH

share|improve this question
    
I'm not sure about OSX, but Linux have no trouble accessing NTFS partitions - no reason to use FAT which is kinda not terribly reliable. –  Sergey Dec 29 '12 at 1:11

1 Answer 1

Linux (and thus Ubuntu) does not use drive letters. Look on your desktop or in the /media folder

If that doesn't help, read up on linux "mounting" and USB especially (Ubtunu Mount/USB page is as good a place to start as any)

share|improve this answer
    
Hi, the drive mounts no problem on linux systems and Mac OSX, just not on Windows 7. –  James Hare Dec 29 '12 at 0:20
    
Then this is not an ubuntu question. You should probably assign the drive a drive letter: pcsupport.about.com/od/windows7/ht/… –  dtech Dec 29 '12 at 0:28
    
I would do this if I could but this option doesn't come up under computer management. When I go there the drive is listed as unallocated and there isn't the option to assign a letter, just reformat. –  James Hare Dec 29 '12 at 0:37
    
make sure you formatted as FAT, give the output of mount –  dtech Dec 29 '12 at 0:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.