Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an issue where my desktop is covered with the contents of my Home folder rather than my Desktop folder. I've tried following this post: Ubuntu desktop suddenly points to home folder but to no avail.

enter image description here

If anyone has any tips that would be great :)

share|improve this question

3 Answers 3

up vote 3 down vote accepted

Check this setting using the Dconf Editor (dconf-tools):

org > gnome > nautilus > preferences > desktop-is-home-dir

Uncheck it if it's checked.

You may need to reboot so the ~/.config/user-dirs.dirs file can be rewritten and reloaded.

share|improve this answer
    
Thank you, it was unchecked, so I checked and unchecked it to refresh it and it worked! Thanks :D –  Gemn Dec 29 '12 at 13:16

This can also happen when you delete ~/Desktop directory. If this is the case just simply recreate ~/Desktop directory (or change where the XDG_DESKTOP_DIR= points in your ~/.config/user-dirs.dirs file)

share|improve this answer

With Ubuntu Tweak, click on Tweaks > Desktop Icon Settings. Then uncheck the check box related to " Show contents of "Home Folder" " (the last one at the bottom).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.