Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Here's my situation:

  • Ubuntu 12.10
  • Several drives/partitions: 200gb partition on ssd, 20gb partition on ssd for Ubuntu, then some old hard drives and a dvd drive

When I start up Ubuntu, I try to open up something like Sublime Text. It will look for the last loaded project, which is on the 200gb ssd partition, but it will fail to find it. So in Nautilus I check out /media/[user] and I see that only the DVD drive is listed in there. However, in the left menu in Nautilus it shows the drives are there. When I click on the 200gb ssd partition it seems to load it up for a second and then it shows the contents. Then when I immediately return to /media/[user], the 200gb partition is there and all is right in the world.

I assume this has something to do with mounting drives, but I'm not sure. How do I get it to automatically load up without me having to navigate directly to the partition first?

Thanks!

share|improve this question

1 Answer 1

up vote 1 down vote accepted

For the partition to be mounted during boot you need to add a line to /etc/fstab file, like this:

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda3
UUID=b2d904e2-139c-498f-b076-d3a05a02902b /            ext4    relatime,errors=remount-ro 0       1
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/sdb1       /mnt/disk       ext4    relatime,errors=remount-ro      0       1

the last line mounts /dev/sdb1 partition into /mnt/disk directory (which you will need to create manually first).

See man fstab for more details.

share|improve this answer
    
Thanks @Sergey...I'm going to try that out and will report back shortly. –  treeface Dec 28 '12 at 21:56
    
Alright so this answer is correct, but I went about it in a slightly more user-friendly way. I installed mountmanager (you can find it in the software center), then ran it. I made sure that each partition that I wanted to automount had "Mount the partition during start of the operating system" checked. Then I did Partition => Apply. This overwrote the /etc/fstab with all of the required lines. Worked like a charm. Thanks for guiding me along my way, Sergey! –  treeface Dec 29 '12 at 0:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.