Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I accidentally installed KDE on my Ubuntu 12.04 Machine the other day, to find I really don't have a liking for it. I runned a apt-get command to remove the kde-full package, but programs like Konsole, Kmouth, and the KDE login screen still remained on my machine. I've looked at other posts on this community, but none of the methods have worked for me so far. Somebody has recommended to use an apt-get command to remove all traces, but this what I recieved:

Virtual packages like 'kdepim-groupware' can't be removed Virtual packages like 'mysql-client-core-5.1' can't be removed Virtual packages like 'mysql-server-core-5.1' can't be removed Virtual packages like 'plasma-widget-kimpanel-backend-ibus' can't be removed E: Unable to locate package kdepim-wizards E: Unable to locate package libattica0 E: Unable to locate package libgps19 E: Unable to locate package libkwineffects1abi2 E: Unable to locate package libkworkspace4 E: Unable to locate package libokularcore1 E: Unable to locate package libplasmaclock4abi2 E: Unable to locate package libtaskmanager4abi2 E: Unable to locate package libzip1

I really don't care, I currently use Unity and GNOME and I don't mind if KDE sits there. But, it would be nice to return to the default login screen.

share|improve this question
    
I've got the same issue, tried the answers here as well as on this question and none work, I'll bounty as soon as possible if noone has posted before then. –  Oyibo Dec 28 '12 at 20:13
    
I've seen the first one, tried the command for the most popular answer, you can see the output above. I've willing to bounty if this doesn't work out. –  sharksfan98 Dec 28 '12 at 20:15
    
Whats strange is in my case I used that command and it "worked" without any bugs, but when I log in I get the kde login, I just prefer unity's aesthetic looks for the login screen but its strange... –  Oyibo Dec 28 '12 at 20:20

2 Answers 2

up vote 5 down vote accepted

sudo dpkg-reconfigure kdm

there should be a menu popping up, asking you which the default display manager should be.

Then restart your PC.

share|improve this answer
    
Tried it already, set it to lightdm but unfortunately didn't work in my case, I'm guessing sharksfan98 will also have already tried. –  Oyibo Dec 28 '12 at 20:20
    
@Oyibo you should also type sudo restart lightdm after choosing I suppose –  Dialogos Dec 28 '12 at 20:20
    
It said that package gdm is not installed and no info is available. Should I download that file? Is it in the universal repository? –  sharksfan98 Dec 28 '12 at 20:21
1  
sorry i ninja-edited it, it reads as kdm now xD –  Dialogos Dec 28 '12 at 20:22
    
Oh... Changed it to lightdm and restarted it, but then received "restart: Unknown instance:" –  sharksfan98 Dec 28 '12 at 20:24

To remove the kde programs:

sudo apt-get purge kdm kubuntu-desktop (or kde-full as needed)
sudo apt-get autoremove

To reset the Ubuntu boot theme:

sudo update-alternatives --config default.plymouth

then choose the option you want. Follow this with:

sudo update-initramfs -u

Run

sudo update-grub

before rebooting. This should also set the login screen back.

share|improve this answer
    
Good additional steps to take in order to wipe out more traces of KDE, but in order to answer the initial question - about the login screen - I would recommend adding kdm to the list of packages to remove (to be sure). –  gertvdijk Dec 28 '12 at 21:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.