Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I would like to install AMD driver, however, I'm afraid because of past experiences after installing proprietary driver from Additional drivers. Everytime I installed be it ubuntu 11.04 or 12.04, After rebooting, I get a blank screen, and don't know how to get back.

Can anyone tell me, how to recover from a blank screen after installing AMD driver if i get so?


share|improve this question

marked as duplicate by stephenmyall, Mik, hhlp, Thomas Ward, Eric Carvalho Mar 9 '13 at 0:04

This question was marked as an exact duplicate of an existing question.

Follow this link.Download 12.11 driver that is the beta version of the driver.… – Mukund Dec 28 '12 at 20:07

You will find a great article in this Wiki Guide with recommendations, issues troubleshooting, and more.

I'll recommend you (from my own experience) to install the latest Catalyst Diver manually. I did followed the instruction mentioned in that link and now my system is working like a charm.

  • My system: Ubuntu 12.10 64bits
  • My graphic card: ATI RadeonHD 6670
  • My driver: Catalyst 12.11 beta x86_64

If you face trouble while installing, you should Ask a new Question in this site explaining the issue.

If after install the driver you see watermark, see this question where you will find a solution.

NOTE: all the procedures that you do are at your own risk

share|improve this answer

if you want to revert, all you have to do is right click anywhere in the blank screen and click on 'change desktop background. from there you go to click the all settings button on the far top left corner of the window. you either look for additional drivers or software source. if you go into software source, you will see a tab that says additional drivers on the far right top corner. in there you will see 3 video drivers. select and enable the one that says xorg. that is the one that works so far.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.