Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to get my Cyborg RAT 3 Mouse (or R.A.T. 3) to work on Kubuntu 12.10 64bit. There are plenty of guides to get it working; they all say you need to add a few lines to the xorg.conf file. Here is an example of one suggestion on Ubuntu Forums:

# RAT3 mouse
Section "InputClass"
Identifier "Mouse Remap"
MatchProduct "Saitek Cyborg R.A.T.3 Mouse"
MatchDevicePath "/dev/input/event*"
Option "ButtonMapping" "1 2 3 4 5 0 0 8 9 0 0 0 13 14"
EndSection

The mentioned configuration does not work. After opening a few windows, the same issues occur again. I have lost track of all of the countless guides, which all suggest adding a variation of the above configuration. I don't like this hit-or-miss game of searching for guides; I have no clue WHAT exactly that configuration is doing. I tried to look at the xorg website for information, but I can't find anything. The manual page for the xorg.conf file doesn't even mention "InputClass" or "ButtonMapping".

I am willing to try another configuration if it worked for you. I would really like to understand what is going on here, though. I would greatly appreciate an explanation of what those settings are doing, or a link to documentation so I can try to fix it on my own. I am going to further look up documentation and will edit this post when I find anything.

share|improve this question

3 Answers 3

up vote 0 down vote accepted

Well, I eventually determined that with the xorg.conf I mentioned above from Ubuntu Forums, it works until I press either of the mode buttons (one changed a colored LED, and another changes the sensitivity of the pointer). Using an answer to another askubuntu question about R.A.T.3 mice, I was able to figure out that buttons 10 through 14 correlate to those mode buttons. So in the above configuration, I changed 13 and 14 to 0's, and now it works! Here is the configuration I am currently using:

Section "InputClass"
Identifier "Mouse Remap"
MatchProduct "Madcatz Mad Catz R.A.T.3 Mouse"
MatchDevicePath "/dev/input/event*"
Option "ButtonMapping" "1 2 3 4 5 0 0 8 9 0 0 0 0 0"
EndSection

The functionality of the two mode buttons is preserved, as they operate with the mouse's on-board firmware. Although I changed the MatchProduct line, but it appears that the configuration works either way.

share|improve this answer

The trick I found, after pursuing the same routes/dead ends as you, is that the MatchProduct value MUST match the actual product name as listed by xinput -list, like this:

metz@nnnnnnnnn:~$ xinput -list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Mad Catz Mad Catz R.A.T.5 Mouse           id=10   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Chicony Saitek Cyborg Keyboard            id=8    [slave  keyboard (3)]
    ↳ Chicony Saitek Cyborg Keyboard            id=9    [slave  keyboard (3)]
    ↳ Microsoft® LifeCam Cinema(TM)             id=11   [slave  keyboard (3)]
    ↳ IR-receiver inside an USB DVB receiver    id=12   [slave  keyboard (3)]

In my case, the mouse is a R.A.T 5, but I suffered all the same issues (I beleive the RAT7 also suffers).

I changed my settings exactly as you detailed above for the ButtonMapping, but I had to correct my MatchProduct as shown. I first tried to change it to "Madcatz Mad Catz R.A.T.5 Mouse"...but that didn't work. Changing it to "Mad Catz Mad Catz R.A.T.5 Mouse" worked fine. So that answer is...make sure the value of MatchProduct....matches...the....product ;):)

share|improve this answer

I used the above lines suggested by drdrez (thanks btw) with lines someone else suggested.

Hit Ctrl+Alt+T for a terminal window:

Type sudo gedit /etc/X11/xorg.conf

and inserted this:

Section "InputClass"
Identifier "Mouse Remap"
MatchProduct "Madcatz Mad Catz R.A.T.3 Mouse"
MatchDevicePath "/dev/input/event*"
Option "ButtonMapping" "1 2 3 4 5 0 0 8 9 0 0 0 0 0"
EndSection


Section "InputDevice"
       # generated from default
       Identifier     "Mouse0"
       Driver         "evdev"
       Option         "Name" "Saitek Cyborg R.A.T.3 Mouse"
       Option         "Vendor" "06a3"
       Option         "Product" "0ccc"
       Option         "Protocol" "auto"
       Option         "Device" "/dev/input/event4"
       Option         "Emulate3Buttons" "no"
       Option         "Buttons" "7"
       Option         "ZAxisMapping" "4 5"
       Option         "ButtonMapping" "1 2 3 4 5 6 7 0 0 0 0 0 0 0"
       Option         "Resolution" "3200"
EndSection

Fixed my RAT 3 mouse in Ununtu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.