Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After since I cancelled the updates in the last stage (making changes to database<setting AppArmour>) and hard-rebooting my laptop with ubuntu 12.04 (64 bit) is stuck at the startup screen :- The screen just before the username/password prompt with blinking dots. I have tried to run the previous versions but with no help.

I can't even login to terminal.

Please help; I don't want to reinstall or loose my data.


Edit:- I've been able to drop to the root shell from the recovery mode; is there a way I can get the things normal?

Any help is much appreciated.

share|improve this question
    
yes i tried recovery mode and tried to fix broken packages but even after waiting for 1 hour or got no help. –  Ankit Dec 28 '12 at 18:23
1  
This Question covers many black screen issues askubuntu.com/questions/162075/… –  Chris Carter Jan 1 '13 at 12:15
    
@ChrisCarter I don't agree with it being a duplicate of that one. This is probably a specific broken package causing a boot failure. Ankit could provide the last lines of failure from ˋ/var/log/apt/term.logˋ for more information on what exactly went wrong. –  gertvdijk Jan 1 '13 at 15:27
    
@ChrisCarter Also, this is not a black screen at all. The screen with the dots is the Ubuntu splash screen. Pressing Esc or F2 at this screen will reveal messages documenting what has happened as Ubuntu has tried to start up; some may be useful. –  Eliah Kagan Jan 1 '13 at 15:58
add comment

1 Answer

I recently had a similar problem - in my case, the .profile file had become corrupted. Move this to .profile_old and try logging in again. The only other problem I am aware of that can cause this is a bad Xorg conifguration - you might check that that's all correct too if the first suggestion doesn't help.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.