Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I had to install some new packages in my server, but the version of Ubuntu (10.10-maverick) is not supported anymore. So, when I tried with apt-get update, I got lots of 404 not found messages.

I didn't know I could change the sources.list using the old-releases addresses, so I changed my sources.list with the repositories in the next newer supported version (11.10).

I executed apt-get update, and it worked. Then I installed the new packages without problems. I could see some of the old packages (like libc, perl, etc) were updated too.

Until now, everything seems to work fine, but I don't know if this solution can give problems in the future. I'm a little afraid about this, because the server is on production and many people depend on the services on it. I don't want to install new packages using the new sources.list if I am going to get problems of libraries or similar.

Can you help me? Thanks in advance.

share|improve this question
    
10.04 is lucid are you sure it's not 10.10 maverick you are on? –  Alvar Dec 28 '12 at 17:29
    
This can be hairy if you're not an expert with apt, whichever answer you choose you need to do this in a maintenance window and with plenty of time to resolve the issues. –  Jorge Castro Dec 28 '12 at 17:42
    
Sorry I confused the number version. It's 10.10. thanks –  Jean Michel Dec 28 '12 at 17:44
add comment

4 Answers

The correct way to upgrade an Ubuntu system to the next release is using do-release-upgrade. That tool downloads a set of upgrade scripts, different for each Ubuntu release, that will not just update your sources.list, but also tune some settings.

You said that you were on Maverick and then you skipped to Oneiric. This means that you have not run the Natty and Oneiric script sets. They are:

You can download and extract these two tarballs and examine the content, looking at the actions that the scripts would have performed. Note that you will find some uninteresting scripts, for example the Nvidia-related scripts (which, on a server, do not need to be run). It's safe to skip them.

Once you have identified the scripts that would have run if you did the upgrade correctly, you can try performing the actions of that scripts. Examining the scripts can also help you detect the potential problems that your upgrade may have introduced.

By the way, do test your server's services deeply. This is the only way to know for sure if everything works correctly. If everything works, then you don't have to worry (obviously, this sentence is true only if you have performed accurate and complete tests).

Finally, I'd like to point you to the answer of this question: How to install software or upgrade from old unsupported release?. It's too late to apply the procedures described there, however the next time you'll know what to do.

share|improve this answer
    
Good answer Andrea. I tested the main server services I'm using (Apache, Mysql, etc) and they are working fine. But in my inside I now something could have been broken. That's why I'm thinking more on "undoing" than in "upgrading". But I don't know if this two options could get worse my server instead of fixing it completely. –  Jean Michel Dec 28 '12 at 18:00
    
@user117269: undoing an upgrade can introduce real, serious problems, I would not consider it an option. Instead, look at what the proper upgrade tool would have done to your system and try to do that yourself. –  Andrea Corbellini Dec 28 '12 at 18:29
    
@user117269: I've updated my answer adding some details that you may find useful. –  Andrea Corbellini Dec 28 '12 at 19:11
    
Thanks again. That should have been my step, if only I had known that! Lesson learnt :) –  Jean Michel Dec 29 '12 at 17:51
add comment

If you do a sudo apt-get upgrade or sudo apt-get dist-upgrade now it will pull all the new packages from 11.10, essentially upgrading you to 11.10.

share|improve this answer
    
Thanks all for your fast answers!. I'm very afraid now that understand more exactly how dangerous it's what I've done. I would like to "reverse" this changes because the new installed packages are not important to me right now, but I prefer to have the server stable. I didn't get errors until now, but I saw that some important libraries like libc were updated. I think this could be a 'hidden bomb' ready to explode in the worst moment. So I would like to anticipate to that bomb. What would you do in my case? Helps a lot to all for your help, again! –  Jean Michel Dec 28 '12 at 17:49
    
@user117269, you can not reverse the changes, and must not continue to run an unsupported release as it will no longer get security fixes. Best thing is to make sure all packages upgraded and services appear to be running ok. Then you should use the correct do-release-upgrade method to upgrade to 12.04 LTS. –  psusi Dec 28 '12 at 18:17
    
Thanks psusi :) I'll take into account your good advices. I need to learn conscientiously all the steps to do it in the best way, because I have no experience doing it in production servers. –  Jean Michel Dec 28 '12 at 18:36
add comment

Ubuntu packages, unlike windows probably, run only specific versions only. For example, a package(an application) "made for" Ubuntu 10.04 will run only on 10.04 without hiccups. If you try to install this package on 11.10 or any higher or lower version, it may run but can cause dependency and likewise other errors. Therefore, it is recommended that you either upgrade to another LTS version, since your system is very much busy and can't be frequently upgraded or less recommended, continue using your old Ubuntu without updating and hence upgrading the packages. Installing packages belonging to a different version by modifying sources.list is, on my part, asking for trouble.

share|improve this answer
    
Thanks John. I was afraid to receive this answer. I think you're right and I noticed I was wrong just when I started my update, but I could not abort it once it started. So, I would feel more comfortable if I could "undo" this, but I don't know if I can. I just installed two packages, but they had deps and updated other important packages like libc,perl etc. –  Jean Michel Dec 28 '12 at 17:55
    
Perhaps you can try a sudo apt-get purge package-name, though the updates could not be undone, I feel. Please post your query if this link does not help you. –  Jobin Dec 28 '12 at 18:01
    
Thanks again Jobin :) I'm going to wait until Monday to know if everything continues working fine. If something broke, I will try to purge the installed packages as you recommend me, and then I will report here. My main fear is with the other dependencies that were updated, like libc. I think they can not "come back" to the previous version, so if the problem comes from it, maybe a complete upgrade will be necessary. –  Jean Michel Dec 28 '12 at 18:13
    
There are many good people around here @user117269 who'll help you out for such issues. So you can have a happy time till Monday, and afterwards too! So, don't worry about this, and keep reading about related posts, hope you get a better option. –  Jobin Dec 28 '12 at 18:17
    
Good people like you Jobin! thanks a lot for your words, they calm down me after the panic moment I suffered some hours ago when I thought I was in a unsolved mess. Have a good weekend! –  Jean Michel Dec 28 '12 at 18:26
add comment

I think I just made it by replacing some lines on repositories list /etc/apt/sources.list: it seems the server is not called archives.ubuntu.com but old-releases.ubuntu.com. I just replaced all the archives. entries by old-releases. leaving the rest as is. I also deleted us. entries.

Hope it works for you too.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.