Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having problems installing the drivers for internet connectivity from service provider. My computer recognizes the files when I insert the stick but does not want to install the drivers when I click on the .exe files.

share|improve this question
3  
Please give more details. What is the model of the device? Which service provider? Is it wireless, ethernet, dialup, other? –  dv3500ea Aug 15 '10 at 21:15
2  
Also, be warned that an *.exe file is a Windows executable (unless it's a self extracting archive), and won't work under Linux –  Xuacu Aug 15 '10 at 21:46
1  
Your ISP should not need drivers, just your hardware. Are you trying to configure a router? You can do that in a web browser instead of with the CD they come with. –  maco Aug 15 '10 at 21:51
2  
Never install ISP-provided "drivers". They are almost never necessary, despite what they tell you. –  Dennis Williamson Aug 15 '10 at 22:03
    
Can we actually run .exe on Ubuntu without using Wine?? –  User Aug 16 '10 at 18:31

5 Answers 5

up vote 1 down vote accepted

When you see the windows drivers on the modem it is in USB-drive state. You need to install usb-modeswitch to toggel it in to modem mode. This is also what namkid is refereing to as "flip flop USB". You can install this tool from the software center.

share|improve this answer

Is not necessary install other software,the NetworkManager recognizes the USB modem,only connect the modem and wait...

share|improve this answer
    
As far as I know you do not need any additional software. I concur with AJenbo. When you insert your modem and it brings up the connection screen, make sure that you wait or the network provider signal before you click connect. –  namkid Sep 5 '10 at 19:09

I installed a 3G USB modem...did the following: There was a problem the USB modem (which the service provider replaced)...downloaded "flip flop USB" from Ubuntu software centre for network recognition...installed "mobile partner"(may have a different name with other providers) for Linux for USB(internet) login...if necessary, make sure that proxy settings are set to "no proxy"...thanks everyone taking the time to read and post answers...hope my experience will be of some value as well

share|improve this answer

To connect with my mobile as a 3G modem (via usb cable) I had to use the wvdial package to get it to work...

try:

sudo aptitude install wvdial

and then:

sudo wvdialconf

Elsewhere you need to tell us some more detail on what modem you are trying to get to work...

share|improve this answer
    
I installed a 3G USB modem...did the following: There was a problem the USB modem (which the service provider replaced)...downloaded "flip flop USB" from Ubuntu software centre for network recognition...installed "mobile partner"(may have a different name with other providers) for Linux for USB(internet) login...if necessary, make sure that proxy settings are set to "no proxy"...thanks everyone taking the time to read and post answers...hope my experience will be of some value as well –  namkid Aug 18 '10 at 13:48

I am not sure that you necessarily need to do this, it depends on what network interface you are trying to install.

However assuming it is a wireless card and that you really do require the windows drivers you may find what you need to know on the ndiswrapper page of the Community Ubuntu Documentation.

share|improve this answer
    
I installed a 3G USB modem...did the following: There was a problem the USB modem (which the service provider replaced)...downloaded "flip flop USB" from Ubuntu software centre for network recognition...installed "mobile partner"(may have a different name with other providers) for Linux for USB(internet) login...if necessary, make sure that proxy settings are set to "no proxy"...thanks everyone taking the time to read and post answers...hope my experience will be of some value as well –  namkid Aug 18 '10 at 13:47
    
@namkid: If what you did fixed your problem you should add it as an answer and then accept it, this makes it easier for others to find the correct answer. There is nothing wrong with answering your own questions. –  Richard Holloway Aug 18 '10 at 14:40
    
Will do Richard...Thanxs –  namkid Aug 25 '10 at 14:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.