Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently encountered a huge problem when installing diablo 3 on playonlinux (PoL). The game launch menu started but when I click on the play button the window close immediately and there is just diablo iii.exe process running in background.

The debugging console of playonlinux showed during the process:

Direct3D9 is not available without OpenGL.

I suspect that the 32bit nvidia openGL lib is not installed or loaded. My first question is how do I install the nvidia-glx package without gettng the following error?

   Reading package lists... Done
   Building dependency tree       
   Reading state information... Done
   Package nvidia-glx is not available, but is referred to by another package.
   This may mean that the package is missing, has been obsoleted, or
   is only available from another source

   E: Package 'nvidia-glx' has no installation candidate

currently, I am running Ubuntu 12.04 LTS (precise) using quadro 2000m with the latest Nvidia driver 310.19 installed (thinkpad w520). I am pretty sure i have installed opengl 32bit libraries during the driver installation in recovery mode, but somehow this still doesn't work.

Following is the xorg.conf file generated by the nvidia-xconfig. Is this configuration correct or do I need to modify it to load glx module?

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 310.19  (buildmeister@swio-display-x86-rhel47-             08.nvidia.com)  Thu Nov  8 02:09:12 PST 2012


Section "ServerLayout"
Identifier     "Layout0"
Screen      0  "Screen0" 0 0
InputDevice    "Keyboard0" "CoreKeyboard"
InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"
EndSection

Section "Monitor"
Identifier     "Monitor0"
VendorName     "Unknown"
ModelName      "Unknown"
HorizSync       28.0 - 33.0
VertRefresh     43.0 - 72.0
Option         "DPMS"
EndSection

Section "Device"
Identifier     "Device0"
Driver         "nvidia"
VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
SubSection     "Display"
Depth       24
EndSubSection
EndSection

Any suggestion and help to solve this problem is much appreciated.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.