Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Dell Inspiron 5420 (14R 3rd gen). Wireless and wired works fine in Windows 7, but I do not get any in Ubuntu 12.04. lspci gives the following data:

02:00.0 Network controller: Broadcom Corporation Device 4365 (rev 01)
03:00.0 Ethernet controller: Atheros

I tried using this link answer: Drivers are not detected on my Dell Inspiron 5420 (14R 3rd generation) but I get the following error :

bash: ./scripts/driver-select: Permission denied
share|improve this question

I have a Dell Inspiron 5420 Laptop. I was struggling to install Wired Network drivers. The article above helped me in installing them. But after installing the wired network successfully, I tried to install Wireless Network drivers. I found out that I have "Broadcom Corporation Device 4365 (rev 01)" after typing lspci on the terminal.

I also tried the wireless setup guide given above, but was unable to install it, because it was saying that I have the i386 package installed and I cannot use amd64. After trying many different things, I tried to update my Ubuntu 12.04 to studio i386.

After all the updates were successfully installed. The system automatically asked me to install Broadcom Wireless, by clicking "yes" all my troubles were gone and now it is working smoothly.

share|improve this answer

Download the driver from here

and copy that driver to desktop.

Open terminal (Alt+ Ctrl + T) and paste the following commands one by one.

cd ~/Desktop
tar -xvf compat-wireless-2012-07-03-p.tar.bz2
cd compat-wireless-2012-07-03-p
scripts/driver-select alx
sudo make install
sudo modeprobe alx

Now you are able to connect the Internet. Happy Ubuntu..!!!

share|improve this answer
-1 for building from source. compat-wireless updates are available using packages. Try apt-cache search linux-backports-modules-cw. – gertvdijk Dec 28 '12 at 11:18

Try installing more recent wireless drivers (kernel modules) using backported compat-wireless modules. Ubuntu has packages available for this.

For example, try installing the package linux-backports-modules-cw-3.6-precise-generic and just to be sure, install the firmware modules as well. Example command:

sudo apt-get install linux-backports-modules-cw-3.6-precise-generic linux-firmware linux-firmware-nonfree

This metapackage will install the appropriate backported kernel modules from the Linux 3.6 source for your current Precise kernel (3.2). For the linux-firmware-nonfree you'll need to have the multiverse repository enabled (see this question on how to do that).

Then reboot and see if your wireless adapter is recognized properly.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.