Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

As many I deleted the Templates on a fresh install. I followed the instructions in the accepted answer of What is the templates folder in the home dir for? I am running 12.10 and the proposed solution to restore the templates functionality does not work.

I did reboot. I tried a .Templates folder and a Templates folder and I played with XDG_TEMPLATES_DIR="$HOME/Templates". I added empty libreoffice files etc. All without success.

How can I restore template functionality in 12.10?

share|improve this question
btw, I think the Templates dir should contain a README placeholder on a fresh install. – don.joey Dec 28 '12 at 9:22
up vote 2 down vote accepted

Use Ubuntu Tweak , It comes with some pre-installed template that you can add to your shortcuts in tweak section.

Ubuntu Tweak Admins Page

Template Section Of Ubuntu Tweak

Adding Templates To Your Template Folder

View Of Your Template Folder After Adding Templates

share|improve this answer
If you have deleted the templates folder, however, you first have to add in Ubuntu Tweak/Admin/User Folder. – don.joey Jan 3 '13 at 17:11
To clarify, just in case, in Ubuntu Tweak, select Admins, select User Folder, and then select the Templates line. Click Restore. – H2ONaCl Jun 6 '13 at 6:20

You have to tell the system where your template directory is first:

$ gedit ~/.config/user-dirs.dirs

Then edit: XDG_TEMPLATES_DIR="$HOME/Templates"

Now, just drop any blank document from LibreOffice, a text editor or other into ~/Templates.

When you right click in a Nautilus directory it will offer to open a new document with all the properties of the one you planted in Templates. Damn useful!

share|improve this answer
It appears the OP tried that and found it to not work, hence the need for this question. It didn't work for me either, even after a reboot. – H2ONaCl Jun 6 '13 at 6:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.