Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I turn on my computer (a CR-48), I keep loading tty1. I have tried xstart, and all I get is:

Fatal server error:
Could not create lock file in /tmp/.tX0-lock

When I attempted to make the directory (both sudo and not), I received these two errors:

sudo: Can't open /var/lib/sudo/don/tty2: Read-only file system (I've gotten other tty's for different virtual terminals)
mkdir: cannot create directory '/tmp/tX0-lock': Read-only file system

Before I got to the only terminal state, I had the computer moving a few files from a network server to the computer, I put it to sleep without stopping the transfers, and started the computer again away from my home network, and attempted to stop the transfers, the computer than restarted.

Running sudo reboot puts me right back in the virtual terminal, and I can't get into any sort of x application.

share|improve this question
I suppose xstart is a typo: the command is startx. – Sid Jan 26 '11 at 14:04
You might have a partition that's full. Can you check that? – lmontrieux Jan 26 '11 at 14:14
Change the title so something like "Failure to start X Server". – user4124 Jan 26 '11 at 14:18
Similar question at Super User: Ubuntu boots into command line instead of X. – Sid Jan 26 '11 at 14:32
up vote 7 down vote accepted

The hard drive is read only because it's got some errors on it. These have been detected during a scan and now your drive is read only. You need to run fsck against your main root partition while the partition isn't mounted or read only. It's read only so you should just have to run fsck.

If it's possible to run the LiveCD, you can use the gui tools to fix the issue, you can do all this using the System > Administration > Disk Utility once you're booted into the LiveCD desktop:

disk utility screen

Once you've run the checks, make sure your disk isn't full (delete some stuff if you have to) and then reboot.

share|improve this answer
I can't load into a portable operating system. It's a CR-48, I had to hack it just to install ubuntu. – dkuntz2 Jan 26 '11 at 16:18
I must add that this method of fixing this issue is VERY similar to the way you would fix the same issue on a Mac. – djangofan Jan 24 '12 at 21:15

It seems your filesystem has problems, and has mounted itself in "read only" mode. There could be a lot of causes.

I'll go out on a limb and suppose that you have only one root filesystem. Try to reboot like this:

shutdown -r now -F

This will mark the filesystem as "dirty", and check it on reboot. It doesn't guarantee that it'll fix it, but could help.

You could also try to remount the root filesystem in RW mode. Try this as root:

mount -o remount,rw /

And check if you can write something in /tmp. If you can't, there's not much we can do with the data you provide. Check dmesg to see if there are any obvious errors.

Sorry not to be of much help.

share|improve this answer

Just to add onto this for a chromebook. If you're stuck and need to change something in the filesystem that's read only.

Boot back into the chrome os, then do a Ctrl + Alt + ->

Login as chronos and then login to root

mkdir test
mount -w /dev/sda7 test

Then from there, in test, you can edit the setting that you changed that cause your system to go readonly

then finally: umount test when you're done

share|improve this answer
Don't know why this was down-voted. All it is, is providing help for those with a chromebook using Ubuntu. Pure help. – kentoe Dec 13 '12 at 23:59

My amazing skills of observance led me to seeing that I was being told to run fsck manually. I did that, and everything is fine.

share|improve this answer
So you did exactly what I suggested and it's fixed it? Grrr. – Martin Owens -doctormo- Jan 26 '11 at 16:50
You should mark Martin's answer as best, since he gave you the solution. Then future readers with the same problem will know what to do without wading through everything else. – djeikyb Feb 11 '11 at 12:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.