Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I attempt to view a video file, I get a solid green screen with audio, regardless of the application or file format. This happens with .mp4, .gp, and .dv files.

I am unable to use live web cam with Skype, also getting a solid green screen. I am using 32-bit Ubuntu 12.04 on an iMac.

There is no problem viewing videos on the Internet, i.e. YouTube, etc., and the files I upload to YouTube play normally. I only have problems viewing local files. I do not use VLC Media Player. How do I go about changing the hardware acceleration?

share|improve this question

1 Answer 1

While the root of the problem is likely hidden in your video drivers, a quick fix is to just disable hardware acceleration in Flash. You might experience a slight decrease in performance, but you'll actually get video working again without going to too much trouble.

In VLC Media Player:

  1. Click on Tools --> Preferences

  2. Click on the Video tab

  3. Uncheck the "Accelerated video output (Ovelay) box.

  4. Save these settings and it should work immediately.

For Youtube videos you could do this:

1) Right click on youtube video.

2) Go to settings.

3) UNCHECK the 'Enable hardware acceleration' tickbox.

4) Refeshed and works fine now.

I also recommend you to install/reinstall your video/display driver.

share|improve this answer
    
Solved it for me, thanks! –  BenjaminRH Jul 23 '13 at 2:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.