Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop's media keys (volume up/down/mute) are detected via xev and showkey. I can go into System Settings > Keyboard > Shortcuts and set the volume controls with the media keys. However when I try to use the keys they do not function properly.

I tried setting the keys and rebooting the system but that hasn't worked. Any ideas?

System Info:

  • Dell Latitude E6500
  • Ubuntu 12.04.1
share|improve this question

1 Answer 1

A bit late I know, and only a suggestion (rather than a definite answer) but have you tried looking at the output of xmodmap -pke | grep <keycode_from_xev> (may just be the command line version of that path you tried but worth a go)

If you haven't, and the output is something like keyode <...> = then it might be fixed by creating a .xmodmapfile with the line keycode <...> = XF86AudioLowerVolume (and XF86AudioRaiseVolume for the other key).

You can then use the file with the command xmodmap .xmodmapfile

Also it would be quite helpful if you put xmodmap -pke | grep XF86Audio into the terminal to see if there are any keycodes bound to that.

If that's what you meant you tried when you said you tried "setting the keys" then I apologise.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.