Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to build dasher, but I got it needs glib. So doing so this came up:

Checking for GLIB... configure: error: Package requirements (glib-2.0>= 2.6) were not met:
No package 'glib-2.0' found

So I tried to install libglib2.0-dev Install libglib2.0-dev

It gave another error:

Depends: libglib2.0-0 (=2.26.0-0ubuntu1) but 2.26.1-0ubuntu1 is to be installed
Depends: libglib2.0-bin but it is not going to be installed

What shall I do?

share|improve this question

The problem is that you are installing the package with dpkg, which doesn't install dependencies. You have to use apt-get (aptitude could do too) like this:

sudo apt-get install libglib2.0-dev

This way all dependencies needed will be automatically installed.

share|improve this answer

2.26 refers to GNOME 2.26, which is an old version. Do you have Ubuntu 9.10 or a similar old Ubuntu distribution?

If you can upgrade your distribution, you should be able to solve these problems. If you cannot upgrade, then get an older package of the source code of the program that compiles with dasher.

share|improve this answer
lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 10.10 Release: 10.10 Codename: maverick – las Jan 26 '11 at 13:47
but i have been upgrading from 9, upgrades didnt go well? – las Jan 26 '11 at 13:48

2.26 actually refers to the glib version, not the GNOME version and is current for maverick. I think you might have just hit a time where certain packages are uninstallable if one arch builds before another. Does this still fail to install?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.