Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading to 12.10 I've noticed that I can't install some of the nice apps created for the AppShowdown, such as:

  • Cuttlefish
  • Blubphone
  • (Lightread also came out quite late in 12.10)

It seems such a waste having these great new apps added to the repository, only to exclude them in the first next version.

I'm wondering why aren't these apps automatically available in a newer version of Ubuntu. Is it simply that the API is so different that it requires major rewrites and programmer activity or is it some bureaucratic reason? Are there any plans to improve this process?

share|improve this question
    
"Is it simply that the API is so different that it requires major rewrites" seems a large part of the reason. Even MyUnity has been held up. Here's what the MyUnity devs have to say. –  user25656 Dec 28 '12 at 5:51
add comment

1 Answer 1

up vote 3 down vote accepted

Apps submitted through our MyApps portal will not be automatically added to new releases, the developer is responsible for testing it and re-submitting it for each new release of Ubuntu. If the apps were already approved for 12.04, then as long as they continue to work in 12.10 the review process should be relatively quick.

share|improve this answer
    
Unfortunately review process for opensource and free of cost apps are slower than closed source or paid apps –  Tachyons Dec 28 '12 at 15:32
    
Thanks for the info, Michael. Personally, I think that automatic propagation with bug reports if any problems are detected would be nicer. The usual answer I found when asking MyApps app developers about 12.10 is "just install the old 12.04 .deb file, it still works". Most of the core technologies (e.g. Python, C++, gcc, Qt, GTK) don't change that often and even if they do, they go through the slow and steady deprecation process with warnings etc. Even if an API change causes some program to crash is easy to report and better than 100s of users meddling with old .deb files IMHO. –  kermit666 Dec 29 '12 at 19:15
    
Tachyons, that is a known problem that we're working on solving –  mhall119 Dec 30 '12 at 19:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.