Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed 12.10 on my 11-inch mid-'11 Air without a hitch. I removed Unity and installed Cinnamon in its place. I purged every Unity-related package from the system. Today, the kernel updated and broke my machine. I can't get to the GRUB menu and I am told that the computer is running in low-graphics mode, even though I can't do anything with the options presented by the dialogues. nmcli refuses to connect to my network. I need a way to get the system working again, preferably without using a reinstall or install disk.

lspci -nn | grep VGA produces:

00:02.0 VGA compatible controller [0300]: Intel Corp. 2nd Gen. Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)

X Log

A Happy Update!

Turns out my problem was I never ran update-grub. So right now, I'm rebooting with Unity installed again to see if it makes a difference.

A Happier Update

The problem now seems to lie with the new kernel. It won't recognize my wireless card. But this problem can be considered closed, methinks.

share|improve this question
    
We need more hardware information to help you, can you look at this question and then edit your question adding the information. –  Seth Dec 27 '12 at 23:24
1  
Try to boot into your older kernel. Hold Shift very early during booting and you should be able to get into your Grub menu. You say you "can't get to" it, but that does not sound plausible as your system does boot. If the older kernel does boot correctly, you can provide more information. –  gertvdijk Dec 27 '12 at 23:25
    
@gertvdijk I held Shift through the entire boot. No luck. –  jaccarmac Dec 27 '12 at 23:31
    
@iSeth: added some stuff –  jaccarmac Dec 27 '12 at 23:45

2 Answers 2

jaacarmac solved the problem in his post:

A Happy Update!

Turns out my problem was I never ran update-grub. So right now, I'm rebooting with Unity installed again to see if it makes a difference.

A Happier Update

The problem now seems to lie with the new kernel. It won't recognize my wireless card. But this problem can be considered closed, methinks.

share|improve this answer

When something like this happens to me, I usually boot from an older kernel image - which I choose in the GRUB menu as @gertvdijk already suggested.

Since you don't see the GRUB menu, I recommend you take a look at your conf file:

sudo vim /etc/default/grub

(or substitute with an editor you're comfortable with - nano, emacs...) Check what your values for GRUB_HIDDEN_TIMEOUT_QUIET and GRUB_HIDDEN_TIMEPUT are. If you're ending up with a shell, you must have passed through GRUB. If nothing else works, try setting your GRUB_DEFAULT value to something other than 0 - probably 1 (try experimenting until you pin-point the correct kernel image).

Once you're done editing the file, run

sudo update-grub

to apply the changes.

If this works, a fix will probably be out by the next kernel version, but you can help the process by checking to see if you can report this bug.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.