Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Previously, I had in this Windows installed on this computer, but then I installed lubuntu. There are two HDDs in this computer, and I installed lubuntu in the other, which I had split into two partitions. The partitions which didn't have lubuntu, were formated as ntfs and had some videos on other stuff and they did work properly in lubuntu. Now I have formatted those partitions with ext4, and now when i start my computer, there are two errors:

  1. An error occurred while mounting /media/sdb1
  2. The disk drive for /media/sda5 is not ready yet or not present

and I have to press S in both cases. In lubuntu's file manager, I can see both partitions in the side, but when I try open sb1, it gives me the error:

Error mounting: mount exited with exit code 1 ...

When I try to watch in media directory, there isn't sda2, but sda5. There is also sdb1 and a directory named after sda2 UUID code. Also, all file sizes are very small, like 5KB, even tough the HDD are like 120 GB.

Any help is welcome. It also seems that you always ask for /etc/fstab in this kind of problems, so I put it in the end just in case.

 # /etc/fstab: static file system information.
 #
 # Use 'blkid' to print the universally unique identifier for a
 # device; this may be used with UUID= as a more robust way to name devices
 # that works even if disks are added and removed. See fstab(5).
 #
 # <file system> <mount point>   <type>  <options>       <dump>  <pass>
 proc                                       /proc           proc 
 nodev,noexec,nosuid         0  0  
 # / was on /dev/sda1 during installation
 UUID=cf212a82-6d71-41cf-bd15-6bfe659ed943  /               ext4  
 defaults                    0  1  
 # swap was on /dev/sda3 during installation
 UUID=ccadac6d-83c4-4d68-b5e0-28b6f1533100  none            swap  
 sw                          0  0  
 /dev/fd0                                   /media/floppy0  auto  
 rw,user,noauto,exec,utf8    0  0  
 /dev/sdb1                                  /media/sdb1     ntfs  
 nls=iso8859-1,ro,umask=000  0  0  
 /dev/sda5                                  /media/sda5     ntfs  
 nls=iso8859-1,ro,umask=000  0  0  
 /dev/sdc1                                  /media/sdc1     ntfs  
 defaults                    0  0  
share|improve this question
add comment

1 Answer

Try installing mount manager to allow the hdd to boot with your system.

once done and restarted, if you boot into your system without hitting s.

Open terminal.

Login into root. sudo bash, followed by your password.

Then use.

chown -R username /media/sda5

and repeat the process for your other hdd.

Then reboot and see if that works. it worked for me.

Unable to access second hdd. ubuntu 12.04

share|improve this answer
    
I installed mount manager, but i still had to press s in booting. Should I change some options in that program, or should only installing it help. –  Willie Dec 27 '12 at 23:10
    
open mount manager select the drive you are trying to use from the list on the left. on the right of the screen you should see an option to "mount the partition during the start of the operating system" ensure this is checked. make sure you do both of them. you may have to re partition the disks if you don't mind doing that i used gparted and formatted the entire disk into ext 4. –  Paul Dec 27 '12 at 23:17
    
Those options are already checked, but those error messages still come. –  Willie Dec 27 '12 at 23:26
    
when that happened to me i had to reformat my hdd to ext 4, i had to make the partition table gpt. then i just had to do as i explained earlier. after that you need some one better than me to help. –  Paul Dec 27 '12 at 23:31
    
Well I got it work. Those errors at start went away, when I changed fstab. Then i had to do those things that you told, except for me changing owner in /media wasn't enough, but I had to do it also in /dev directory. Thanks for your help and fast reply. –  Willie Dec 28 '12 at 0:53
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.