Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Ubuntu Software Center is will not launch. I have read several related question and I have tried various suggestions from Ask Ubuntu including this question, but all attempts return the same error messages. I am running Ubuntu 12.04.

sudo apt-get install --reinstall software-center
sudo apt-get update && sudo apt-get upgrade
sudo apt-get install --reinstall python-pkg-resources

All attempts provide the following errors:

Errors were encountered while processing:  
/var/cache/apt/archives/python-problem-report_2.0.1-0ubuntu15.1_all.deb
/var/cache/apt/archives/python-apport_2.0.1-0ubuntu15.1_all.deb  
 /var/cache/apt/archives/apport_2.0.1-0ubuntu15.1_all.deb  
 /var/cache/apt/archives/python-aptdaemon.gtk3widgets_0.43+bzr805-0ubuntu7_all.deb  
 /var/cache/apt/archives/python-aptdaemon.pkcompat_0.43+bzr805-0ubuntu7_all.deb  
 /var/cache/apt/archives/python-aptdaemon_0.43+bzr805-0ubuntu7_all.deb  
 /var/cache/apt/archives/software-center_5.2.6_all.deb

How do I correct these errors and get my system functioning properly?


In response to Lucio's comment:

Running the following two lines of code produced the same errors.

sudo apt-get clean
sudo apt-get update && sudo apt-get upgrade

Continuing with the help file, I ran:

sudo dpkg --configure -a

and received the following errors:

Errors were encountered while processing:
 python-pkg-resources  
 python-aptdaemon  
 python-aptdaemon.pkcompat  
 apport-gtk  
 software-center  
 python-aptdaemon.gtk3widgets  
 gedit-plugins  
 python-problem-report  
 aptdaemon  
 update-notifier-common  
 python-apport  
 flashplugin-installer  
 apport  

Finally, I ran:

sudo apt-get -f install

but this, again, provided the original errors.

I was installing Python 3.3 to use as the default vice Python2.7. Is any of this (from /usr/bin) creating my problem?

*-rwxr-xr-x  1 root         root             4124 Apr 17  2012 pyclean  
*-rwxr-xr-x  1 root         root            11933 Apr 17  2012 pycompile  
*lrwxrwxrwx  1 root         root                8 Aug 14 18:02 pydoc -> pydoc2.7  
*-rwxr-xr-x  1 root         root               79 Aug  1 01:40 pydoc2.7  
*lrwxrwxrwx  1 root         root               12 Aug 14 18:02 pygettext -> pygettext2.7  
*-rwxr-xr-x  1 root         root            22103 Aug  1 01:40 pygettext2.7  
*-rwxr-xr-x  1 root         root              217 Mar  9  2012 pyhtmlizer  
*lrwxrwxrwx  1 root         root               28 Dec 24 01:51 python -> /usr/bin/Python-3.3.0/python  
*lrwxrwxrwx  1 root         root                9 Aug 14 18:02 python2 -> python2.7  
*-rwxr-xr-x  1 root         root          2989480 Aug  1 01:40 python2.7  
*drwxr-xr-x 16 inigomontoya inigomontoya     4096 Dec 24 01:42 Python-3.3.0  
*-rw-r--r--  1 root         root         16327785 Sep 29 05:15 Python-3.3.0.tgz  
*lrwxrwxrwx  1 root         root               29 Aug 14 18:02 pyversions -> ../share/python/pyversions.py  
share|improve this question
1  
The problem is not the SC, but the mentioned packages. You should enter the first two commands of this answer. Notify the result please. –  Lucio Dec 27 '12 at 21:40
    
I followed the tutorial but the result was the same. I updated my question with more details. –  Magellan Dec 28 '12 at 3:34
    
Please also paste large blocks of code into this official Ubuntu tool and attach it into your question where acceptable. Thanks :) –  Mochan Dec 28 '12 at 6:02
    
@user117091 Run the following commands. sudo rm -r /var/cache/apt/archives and then sudo apt-get clean && sudo apt-get update –  Lucio Dec 28 '12 at 18:31
    
The first line kicked me back to a prompt and when I ran the second line I received the message: E: Could not open lock file /var/cache/apt/archives/lock - open (2: No such file or directory) E: Unable to lock the download directory –  Magellan Jan 1 '13 at 18:21

1 Answer 1

If the version of python is the issue, can you please post the output of sudo update-alternatives --config python? If it shows python 3.3 as the default, change it to python 2.7 and then re-install the software-center, otherwise the version of python does not seem to be the root-cause.

share|improve this answer
    
The output is: update-alternatives: error: no alternatives for python. –  Magellan Jan 1 '13 at 18:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.