Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did a fresh installation of Ubuntun 12.10 (kernel v3.5.0.21-generic, 64 bit, US English) on my computer after downloading the ISO from Ubuntu.com.

In order for one of my installed programs to work, I would like to downgrade the current kernel version to 3.2.0.24-generic

Questions:

  1. Is it advisable to downgrade the current kernet version to an older one?

  2. If the answer to (1) above is yes, how do I do it?

As always, detailed instructions on how to issue specific commands at the terminal window are welcome. I am new to Linux and Ubuntu.

Thanks in advance for your help.

share|improve this question
    
Why don't you do a fresh install with Ubuntu 12.04? It comes with kernel 3.2.0-23-generic i think. –  ThiagoPonte Dec 27 '12 at 20:41
    
Possible Duplicate: askubuntu.com/q/71139/44179 –  Seth Dec 27 '12 at 20:45
    
@ ThiagoPonte: Thanks for the suggestion. Where is the official mirror to download Ubuntu 12.04 with kernel version 3.2.0.24? –  n00b Dec 27 '12 at 20:51
    
@ iSeth: Thanks for the link. I surfed to packages.ubuntu.com/precise/kernel and couldn't help noticing there are two kernels: linux-image-3.2.0.24-generic and linux-image-3.2.0.24-generic-pae. Could someone help explain the difference between the two please? –  n00b Dec 27 '12 at 20:53
    
Check this link out. –  Seth Dec 27 '12 at 20:57

1 Answer 1

up vote 5 down vote accepted

Today I needed to downgrade from 3.5.0-24 to 3.5.0-23 (I have both installed). I succeded with the following:

sudo /etc/kernel/postrm.d/zz-update-grub 3.5.0-23-generic /boot/vmlinuz-3.5.0-23-generic

You can find out Your current kernel with:

uname -a

You can find out other kernels installed on Your computer with::

dpkg -l 'linux-*' | sed '/^ii/!d;/'"$(uname -r | sed "s/\(.*\)-\([^0-9]\+\)/\1/")"'/d;s/^[^ ]* [^ ]* \([^ ]*\).*/\1/;/[0-9]/!d'

Mind that You might also need to lock the version of the kernel -- so to prevent it automatic update.

share|improve this answer
    
Please avoid posting the same answer in more than one place. When tempted to do so, typically: (1) the answer should be customized to account for what is different about the different questions, (2) one question should be flagged for closure as a duplicate of another question (you can flag posts with 15 reputation), (3) the answer should really be a comment, or (4) the answer should be posted in the most appropriate place, and one-line comments posted on the other questions summarizing and linking to it. –  Eliah Kagan Feb 12 '13 at 21:08
    
Since your system is 12.10 (or at least is using 12.10 kernels), I'd suggest keeping the answer here, removing the other one, and posting a comment on the other question linking here. –  Eliah Kagan Feb 12 '13 at 21:10
    
the command is uncorrect, since now kernel is at 3.11 version and it's not spotted by your regexp –  garakkio Oct 22 '13 at 18:52
    
@garakkio: gives linux-headers-3.11.0-12 linux-headers-3.11.0-12-generic linux-headers-3.11.0-7 linux-headers-3.11.0-7-generic linux-libc-dev:amd64 to me. –  Adobe Oct 23 '13 at 11:24
    
my bad: didn't spot "other" in "other kernels". Sorry –  garakkio Oct 24 '13 at 7:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.