Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed 10.04LTS on my 2007 iMac (which already has BootCamp and Windows XP) according to the instruction listed: https://help.ubuntu.com/community/MactelSupportTeam/AppleIntelInstallation

Now, when I select the Linux boot from rEFIt, I get a boot error: something like "no boot....."

I did a Partition Inspector analysis using rEFIt and this is what it brings back:

*** Report for internal hard disk ***

Current GPT partition table:
 #      Start LBA      End LBA  Type
 1             40       409639  EFI System (FAT)
 2         409640    134871711  Mac OS X HFS+
 3      134873088    136970239  Linux Swap
 4      558252072    625142407  Basic Data
 5      136970240    558252031  Basic Data

Current MBR partition table:
 # A    Start LBA      End LBA  Type
 1              1       409639  ee  EFI Protective
 2         409640    134871711  af  Mac OS X HFS+
 3      134873088    136970239  82  Linux swap / Solaris
 4 *    558252072    625142407  0c  FAT32 (LBA)

MBR contents:
 Boot Code: Unknown, but bootable

Partition at LBA 40:
 Boot Code: None (Non-system disk message)
 File System: FAT32
 Listed in GPT as partition 1, type EFI System (FAT)

Partition at LBA 409640:
 Boot Code: None
 File System: HFS Extended (HFS+)
 Listed in GPT as partition 2, type Mac OS X HFS+
 Listed in MBR as partition 2, type af  Mac OS X HFS+

Partition at LBA 134873088:
 Boot Code: None
 File System: Unknown
 Listed in GPT as partition 3, type Linux Swap
 Listed in MBR as partition 3, type 82  Linux swap / Solaris

Partition at LBA 558252072:
 Boot Code: Windows NTLDR
 File System: FAT32
 Listed in GPT as partition 4, type Basic Data
 Listed in MBR as partition 4, type 0c  FAT32 (LBA), active

Partition at LBA 136970240:
 Boot Code: GRUB
 File System: ext4
 Listed in GPT as partition 5, type Basic Data

How can I get my Linux partition to boot?

share|improve this question
add comment

1 Answer 1

First, Ubuntu 10.04 is ancient. The desktop version is reaching end-of-life status in just four months, according to the Ubuntu releases page. IMHO, unless you've got a compelling reason for using it, you're better off using 12.04 or 12.10. In fact, 12.10 has a pretty compelling advantage because it ships with a post-3.3.0 kernel, which means that it can boot in EFI mode without the help of a separate boot loader.

Second, the instructions to which you linked seem to describe setting Ubuntu up to boot in BIOS mode. Although this is the traditional way to do it, it's got a lot of drawbacks. IMHO, if your system works properly booting Linux in EFI mode, that's a better way to do it. OTOH, since you've also got Windows XP booting in BIOS mode, you'll get less benefit from booting Linux in EFI mode than you would on a two-OS (Linux and OS X) installation.

My suspicion is that you've got problems because of your BIOS-mode GRUB installation. You don't seem to have a BIOS Boot Partition, which helps out with GRUB. You may need to create such a partition and re-install GRUB. This will likely disrupt your hybrid MBR setup, though, so be prepared to re-create it with gptsync or gdisk.

Alternatively, you could convert your system to boot in EFI mode. My Web page on the topic describes how. You've already done most of what's described there, so you should be able to pick up with "Fixing the Installation" (or even a good chunk of the way through it -- say, step #13).

share|improve this answer
    
Thank you very much, Rod. I have installed 12.04 and not 10.04. Thanks for the catch. What are your thoughts on getting rid of my OSX and running a pure Ubuntu installation on my iMac? I really don't care for my OSX anymore. –  hooya Dec 30 '12 at 5:38
    
Rod, I get this error when I run gdisk in a terminal window: –  hooya Dec 30 '12 at 5:43
    
dyld: unknown required load command 0x80000022, Trace/BPT trap –  hooya Dec 30 '12 at 5:44
    
That's an OS X error that's related to using a binary that was compiled with a more recent version of OS X than you're using. You could try an earlier version of gdisk, download the source code and compile it locally, or run it from a Linux live CD rather than from OS X. –  Rod Smith Dec 30 '12 at 15:48
    
Thanks, Rod. What are your thoughts on just running a pure Ubuntu OS on my iMac? Will I run into the same booting errors/problems? Thanks in advance. Cheers! –  hooya Dec 30 '12 at 16:50
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.