Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded my system to Ubuntu 12.04 on Fri., everything works great but Chrome is giving me issues with most pages.

http://i.imgur.com/pusx6.png

http://i.imgur.com/ZEERk.png

As you can see the graphics in that tab are frozen sort of. If I switch tabs after loading the page and go back to that tab then it looks fine. But for instance on FB if I scroll down and play with any menu item or the advisory icons at the top, it won't popup. I have to switch screens and come back and it then comes up that menu item.

Chrome version is 23.0.1271.97. I can't figure out if this is an issue with the latest Chrome and how to fix or if this is an XFCE problem or Graphics card problem.

I can play games just fine so I don't think it's that. I do remember that in Gnome before switching over to XFCE under the new Ubuntu I had window cutting problems while dragging windows over the desktop. But XFCE doesn't have this problem.

Also if I open any of the pages I have problems with in FF I don't have these same problems.

share|improve this question
    
Sorry, I'm running Ubuntu 12.04 NOT Xubuntu install. It's an original Ubuntu upgraded from 11.04 to 11.10, then 12.04 on Fri. Once upgraded I installed XFCE4 to use as main desktop, so it's Ubuntu not Xubuntu. Also, I tried going to the mentioned pages with ALL extensions disabled and still same results. –  jfreak53 Dec 27 '12 at 17:48
add comment

2 Answers


What I tried: Disabled all Extensions Disabled all Plugins Cleaned the browser and all private data (cache!)

Nothing worked.


I exported all my bookmarks (more then 4000!) and deleted them in Chrome.

NOW THERE WAS NO MORE FREEZING!

I imported the bookmarks back and I now try to keep the list short so there is no scrolling and the freezing almost stopped (only freezing when the list is too long).

share|improve this answer
add comment
up vote 3 down vote accepted

After a lot of investigating, re-installing Chrome, purging options, etc. I found the problem is caused by the internal flash of Chrome in the latest release. Very easy to fix.

First off go to the URL bar and enter about:plugins and press enter. This will bring up the plugins screen. Once there click on the plus icon next to Details to display all plugin details.

Scroll down till you find Adobe Flash Player, it should say 2 files, meaning you have Flash player installed separately in the system. Either way find the first one in the list libpepflashplayer.so and disable this one. If there is a second one /usr/lib/adobe-flashplugin/libflashplayer.so do NOT disable the second one.

enter image description here

Once done you can go to: http://get.adobe.com/flashplayer/

And install the latest version of flash for your system, in this case the page will tell you to download Flash for Firefox if you have it installed, yes this is what you want.

Download and install, in my case I already had Flash installed for FF so it worked immediately no need to install anything else.

Once done, restart Chrome and it works perfectly. Something seems to be wrong with flash for Chrome in the most recent build, so gonna have to leave it off until they fix it.

share|improve this answer
    
I'm having somewhat a similar problem, though disabling flash did not fix. my issue reported here: [askubuntu.com/questions/265875/… I only get freezing tabs when I right click. –  Ahmad Nassri Mar 9 '13 at 13:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.