Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is the error I get when updating Ubuntu:

W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://packages.medibuntu.org precise InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2EBC26B60C5A2783
W: Failed to fetch http ://packages.medibuntu.org/dists/precise/InRelease  
W: Failed to fetch http://ppa.launchpad.net/cooperjona/stormcloud/ubuntu/dists/precise/main/binary-i386/Packages  404  Not Found
W: Some index files failed to download. They have been ignored, or old ones used instead.

What should I do to resolve this?

share|improve this question
    
Medibuntu doesn’t exist anymore. This should be closed. –  Eric Carvalho Feb 16 at 22:34
    
I had this same problem (my medibuntu FFMPEG PPA had a bad key and was yelling on updates). The medibuntu project is closed. what do I do now? –  isomorphismes Feb 17 at 6:59
add comment

closed as off-topic by Eric Carvalho, karel, Braiam, Seth, Minato Namikaze Feb 17 at 5:11

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Eric Carvalho, karel, Braiam, Seth, Minato Namikaze
If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

Medibuntu's GPG key is missing. Run this in a terminal (Ctrl+Alt+T) to install it:

sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring
sudo apt-get update

Also, you have a PPA that doesn't exist anymore. Remove it by running:

sudo apt-add-repository --remove ppa:cooperjona/stormcloud
share|improve this answer
    
Thank you. Now im getting this: W: Failed to fetch ppa.launchpad.net/cooperjona/stormcloud/ubuntu/dists/precise/… 404 Not Found E: Some index files failed to download. They have been ignored, or old ones used instead. –  Qurratulain Dec 28 '12 at 5:44
1  
It seems the ppa is offline. you could remove the ppa: sudo apt-add-repository --remove pa:ppa.launchpad.net/cooperjona/stormcloud/ubuntu/dists/precise/ and then you should be able to update again. –  Dr_Bunsen Dec 28 '12 at 9:17
    
@BinoyBabu Not true! The --alllow-unauthenticated apt-get option applies only to medibuntu-keyring installation. You can just run sudo apt-get install medibuntu-keyring and properly answer the apt-get confirmation requests. –  Eric Carvalho Apr 14 '13 at 13:31
add comment

The above answer is not a recommended method because it just allows installation of packages from unauthenticated sources. To add Medibuntu GPG key, use the following command.

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 2EBC26B60C5A2783

Example output:

binoy@binoy-pc:~$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 2EBC26B60C5A2783
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.YyPJqlfi6x --trustdb-name /etc/apt//trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv-keys 2EBC26B60C5A2783
gpg: requesting key 0C5A2783 from hkp server keyserver.ubuntu.com
gpg: key 0C5A2783: public key "Medibuntu Packaging Team <admin@lists.medibuntu.org>" imported
gpg: no ultimately trusted keys found
gpg: Total number processed: 1
gpg:               imported: 1

Note that this method can be used to solve all missing gpg key warnings.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.