Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

as it is a wpa,wpa2 personal connection but i cant change it in the network wireless setting ...It keeps on coming as a wep connection but when i type my network password the connect button on bottom of dialog box fades out.but when i add some more characters it fades in but with the correct password only we can connect so its useless..As i'm new to linux and want to be a linux user i expect answes from the pros...

share|improve this question
1  
Welcome to AskUbuntu! You may want to add more information on your wireless device, type lspci in a terminal window (opened using Ctrl+Alt+T) and you'll get a list of your hardware, then post the hardware details related to your question as an edit to your original question. Good luck! –  Oyibo Dec 27 '12 at 8:21
add comment

1 Answer 1

I'm not a pro but there may be issues with your particular wifi adapter. Please post the results of this command:

you@linux ~$ sudo lspci | grep 802.11

It should list your wifi device(s).

In particular there has been in the past issues with the Broadcom network controllers. There is a community help wiki page on Broadcom wifi devices and a quick search shows that there other users with problems getting Broadcom wifi devices to work on 12.04.

Hope that helps! It did for me. See my post about it. I had very similar issues as you - greyed out "enable wifi", etc. In particular my solution (after searching the ubuntu forum, ask ubuntu and community help docs) was to remove the STA drivers using the Ubuntu Software Center, and installed the b43 drivers instead. But first I made sure that my wifi adapter was supported by b43 on the linux wireless site.

Good Luck!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.