Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Please note: I am not so much looking for a fix, as there doesn't seem to be one.

However, I want to know why most Window managers ignore my choice of cursor theme and show the default cursor no matter what.

Is there a problem with the architecture of X that causes this?

Why don't some cursor themes show up in GNOME?
Is not the same question.

share|improve this question
    
Which window managers? –  function Dec 26 '12 at 18:46
    
@function gala, compiz, mutter, metacity, xfwm4 (IIRC), enlightenment... –  RolandiXor Dec 26 '12 at 18:57
    
You may know this already, but as a comparison, custom cursors in KDE work fine. There's even a system-setting page to select which cursor you want. –  Sparhawk Dec 27 '12 at 0:20
    
@Sparhawk yes, I know that, but that doesn't help answer the question. –  RolandiXor Dec 27 '12 at 0:34
1  
I thought it might be helpful as a comparison, since it suggests there is something specific to KDE that allows custom cursors. Also, it implies that what is common in KDE and the other window managers is not to blame for the lack of functionality. i.e. it's probably not X-related. –  Sparhawk Dec 27 '12 at 0:44
show 1 more comment

1 Answer

Edit this file /usr/share/icons/default/index.theme and type the cursor theme then logout and login again, it should work on all windows.

share|improve this answer
    
I asked for the reason lol... –  RolandiXor Dec 27 '12 at 1:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.