Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded my Ubuntu from oneiric to precise by accident. Recently I want to learn gtk/gnome programming, so I'm going to install libgtk2.0-dev. I got an error

The following packages have unmet dependencies: libgtk2.0-dev :
Depends: libgtk2.0-0 (= 2.24.10-0ubuntu6) but 2.24.10-1oneiric6~ppa is to be installed
Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

what shall I do?

share|improve this question
    
You've upgraded to 12.04 while using gtk2.0 source packages from a gimp ppa for 11.10. Apparently the ppa versioned it's gtk source packages higher than 12.04. So you can either re-enable the ppa in your sources, edit to oneiric if needed & install from there or get back onto precise packages. The latter is a little tricky but quite do-able –  doug Dec 26 '12 at 20:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.