I upgraded my Ubuntu from oneiric to precise by accident. Recently I want to learn gtk/gnome programming, so I'm going to install libgtk2.0-dev. I got an error
The following packages have unmet dependencies: libgtk2.0-dev : Depends: libgtk2.0-0 (= 2.24.10-0ubuntu6) but 2.24.10-1oneiric6~ppa is to be installed Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed E: Unable to correct problems, you have held broken packages.
what shall I do?