Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use docomo 2G in a modem to browse. when I am surfing, the internet suddenly disconnects("this may due to the network").

but when i try to reconnect, it is not connecting
I have to unplug my modem and plug it, or i have to reboot my system to reconnect it

version ubuntu 10.04
why this happens??

share|improve this question
1  
Can't you upgrade to Ubuntu 12.04 or 12.10? –  Eric Carvalho Dec 26 '12 at 15:54
    
I had a problem with grub for 12.10. i'm running dual os. this version only suits my system –  yuv60 Dec 26 '12 at 15:57
    
Have you installed driver from dongle or you are using generic driver in network-connections ? –  Netro Dec 27 '12 at 7:09
add comment

1 Answer 1

You need to install two software packages to make the internet connectivity work consistently without breaking. They are wvdial and gnome-ppp (The front-end tool to configure wvdial).

1) Install wvdial package

Open terminal,(alt+ctrl+t) and type the following command

sudo apt-get install wvdial

2) Install gnome-ppp

sudo apt-get install gnome-ppp

3) Open gnome-ppp from the terminal.

sudo gnome-ppp

4)You have to enter your docomo 10-digit mobile number in the Username & your password. Phone= *99***1# or if that doesnt work enter phone=*99#. Then press the Setup button below.

5) In the Setup window below, click the “Detect” button to identify the device ID of the USB port in which you have inserted your USB modem. The tool would automatically detect the Device, Type and Speed of your USB modem. Once it has deteced, please the “Close” button below.

Once this is done click on Connect!!!

You could also download and install ixconn. You can get it here.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.