Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I own an Asus UX32VD. I managed to install 12.10 without any problems following the advices on this page. Everything worked as expected, even many of the Fn keys, excluding F5 and F6.

The problem came after upgrading the kernel to 3.5.0-19 and onwards (as suggested by ubuntu update manager) that WMI stopped to work. When executing lsmod I can see far less modules loaded than when I boot with a working kernel and loading those modules by hand does not work. Actually every fn key behaves as if I was pressing fn+f4 (this after loading the modules by hand).

Is there anything I can do to make this work? Shouldn't I be using 12.10 with this hardware?

Right now the solution I have is to manually boot with kernel 3.5.0-18 that seems to work flawlessly.

share|improve this question

1 Answer 1

Ok... solved. The modules directory /lib/modules/ was not present at boot time. Only some of the kernels had the directory present.

Making the directory available at boot time solved the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.