Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I know this question has been discussed thousand times, but I think my situation is little bit different.

I am using a Giada Mini PC this model

The wifi works well with Lubuntu (light version of Ubuntu) but it does not work with Ubuntu. I tried most of the work around in askubuntu and other blogs but it does not seem to work. Please find below detailed information of the install

lscpi -nn 03:00.0 Network controller [0280]: Atheros Communications Inc. Device [168c:0037] (rec 01)

If I modprobe ath9k and ath5k drivers the dmesg does show some wifi antenna details but the wifi (wlan0) does not appear in ifconfig/iwconfig. I did service networking restart but no luck. I also tried that nohwcryp=1 for atheros drivers no luck.

Appreciate any help to get wifi work on this. Moreover, If you are suggesting any apt-get based installation please note that I can't connect wired connection to this so won't be able to go apt-get over internet. I could only download packages in USB stick and install it manually.

Looks like the driver does not has support for 168c:0037 Device ID

share|improve this question
Looks like this may have the solution but it will require to re compile the driver. As I dont have internet access to the device, now I need to get it done on a different machine. – chandank Dec 26 '12 at 7:07

Finally I managed to get it worked. There are two ways to fix it.

  1. Upgrade your ubuntu to 12.10, as it does has updated driver to support the Device ID and type.

  2. Download the compact driver pack, compile install the wifi driver if you are running 12.04 LTS. To do that a) Install all development packages

    sudo apt-get install linux-headers-generic build-essential
    ./scripts/driver-select ath9k
    make install

It should fix it. In my case upgrading the distro take a toll on my resolution. I am using a Mini PC as already mentioned now I guess I have wrestle with the X11 conf to get back my display.

share|improve this answer

I had problems with the atheros ath9k driver when I upgraded my kernel to fix some power management issues.

I downloaded a driver and it solved my wifi problems. This was what I did:

Go to and download the appropiate driver for your kernel.

Unpack the file you just downloaded in a new folder into your downloads folder.
(it should be something like Downloads/compat-wireless-3.5.4-1-snp)
(beware: your filename might be different)

You will probably need the build tools; open a terminal and type:

sudo apt-get install build-essential linux-headers-generic

Then after you have installed build-essential and headers, please do:

cd Downloads/compat-wireless-3.5.4-1-snp
sudo su
make install
modprobe -r ath9k
modprobe ath9k

My computer crashed shortly after the 2nd modprobe, but when I restarted everything ran lightspeed!!!

Maybe this fix won't mess your resolution. Hope it helps!

Credits to chili555 for his post here:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.