Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

EDIT: It is 4 months since I asked this question, more than 1000 views, but the bug is still unassigned on launchpad. I suggest that everybody affected logs in and subscribes himself as being affected.

I have switched off the dedicated graphics:

0:IGD:+:Pwr:0000:00:02.0
1:DIS: :Off:0000:01:00.0

This is the output of the "sensor" - command, whith fan running on full speed:

 radeon-pci-0100
Adapter: PCI adapter
temp1:       -128.0°C  

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +42.0°C  (high = +87.0°C, crit = +105.0°C)
Core 0:         +41.0°C  (high = +87.0°C, crit = +105.0°C)
Core 1:         +41.0°C  (high = +87.0°C, crit = +105.0°C)

Is there a safe solution to this, and when can we expect ubuntu to cover fan throtteling?

EDIT: Weirdly enough, it now suddenly switched off almost completely . Here is the sensor - output again:

radeon-pci-0100
Adapter: PCI adapter
temp1:       -128.0°C  

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +41.0°C  (high = +87.0°C, crit = +105.0°C)
Core 0:         +41.0°C  (high = +87.0°C, crit = +105.0°C)
Core 1:         +39.0°C  (high = +87.0°C, crit = +105.0°C)

This is weird! But the behavior seems to correspond to the bug report filed here: https://bugs.launchpad.net/ubuntu/+source/acpi/+bug/1049064

EDIT: I am running the gnome3- flavour

share|improve this question
1  
Have you tried the power saving tweaks? Info here: wiki.ubuntu.com/Kernel/PowerManagement/PowerSavingTweaks –  functionptr Dec 26 '12 at 3:27
    
@function The only thing there that seems applicable to me is the Intel i915 RC6 - tweak. Since I'm running 12.10, shouldn't it be activated anyway? –  Konstantin Dec 26 '12 at 7:36
    
Yeah, theoretically it should but I've always had to manually activate it. Have you tried the pcie_aspm=force option? webupd8.org/2011/06/linux-kernel-power-issue-fix.html –  functionptr Dec 26 '12 at 14:58
    
try disabling ACPI ubuntuforums.org/showthread.php?t=1839408 –  j0h May 8 '13 at 2:37
    
@j0h Why do you think this will help and what are the drawbacks? –  Konstantin May 8 '13 at 13:06

3 Answers 3

up vote 0 down vote accepted

Check out my answer on launchpad, it seems like the actual root of the problem has been found:

Hi, I think that I should write here as I was also having this problem for over a year. Last week I gave google next try and it occured that it's hardware problem in some of dell's laptops family. I've been using i8k since ubuntu 12.10 till yesterday. Look on this post: http://en.community.dell.com/support-forums/laptop/f/3518/t/19511930.aspx

I've added heat sink like this guy suggested and now everythink works like should without i8kfan. I have checked temperatures and it looks that dell is suppressing fan control in windows with drivers. I've tested it in such way that after turning laptop on I stopped on uboot screen and waited for couple of minutes. Fan shortly hit the maximum so then next step was to boot into windows. Fans stopped immediately after couple of seconds but I've checked and temperature of PCH was always >65Degress. Now after installing termalpad and small copper heat sink temp is ~50 and even on grub menu fans are quiet. I think this is only reasonable solution. Some dell's guy just f-u-c-k-e-d up design cause thermal plate which covers almost all main board is cut on PCH chip so it is without any thermal sink. they should repair such things on warranty. Hope this helps, after over a year it is really pleasant to have it finally quiet.

share|improve this answer

I am not sure if this is a bug, but I have experienced exactly issue in my system(Intel Core i3) after the upgrade. The CPU eventually is heating and tripping up. What I ended up doing was install "Jupiter Applet", and setting Performance="Power saving" to fix the issue. There is some issue in 12.10 release that is causing it. Hope this helps you!!

share|improve this answer
    
This is the link in case you are wondering where to get Jupiter Applet. –  Sandeep Dec 26 '12 at 1:38
    
Jupiter seems to crash: paste.ubuntu.com/1466442 (I'm running ubuntus gnome flavour.) –  Konstantin Dec 26 '12 at 7:33
    
Ok, for some reason it looks like it is running now. And it helps, the fan is running on a sane level again! However, I read Jupiter has been abandoned (last week!) and also it does a lot of display-managing stuff that I don't really need. I would like to have a piece of software that has only the (literally) core functionality of Jupiter. –  Konstantin Dec 26 '12 at 13:52
    
The real fix will probably come in few days (through Ubuntu updates). I saw this issue being raised in ubuntu development forums. I am unaware of the real bug, and Jupiter offerings is just a kludge fix. –  Sandeep Dec 27 '12 at 0:14
    
Can you link me to the thread? This is very good news because the Jupiter fix seems to work only with the proprietary radeon-graphics drivers, which in turn don't work with Gnome 3 at the moment. –  Konstantin Dec 27 '12 at 23:00

Fans are controlled by the hardware. Some hardware has drivers that can take over and allow software control if you desire ( but this is not recommended ). You can use the sensors-detect command from the lm-sensors package to see if you have such hardware.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.