Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed Ubuntu 12.10 on a Lenovo Y500 laptop (2012), video card is Nvidia 650M (no integrated graphics), I'm using driver 310.19. The problem is that I can't adjust brightness at all. If I press the relevant media keys, the indicator in ubuntu works correctly but the brightness is not changed.

So far I've tried the following:

Editing xorg.conf in this way:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option         "RegistryDwords" "EnableBrightnessControl=1"
EndSection

Adding the options acpi_osi=linux acpi_backlight=vendor to the grub boot options

Setting brightness from the terminal and using xbacklight. The values of /sys/class/backlight/acpi_video0/brightness can be changed as well but the brightness remains the same.

Do you have any other hints?

Solution

It is possible to enable the backlight by installing the nvidiabl module. First of all install git and dkms:

$ sudo apt-get install git dkms

Download the code on your machine and compile the package:

$ git clone https://github.com/guillaumezin/nvidiabl.git
$ cd nvidiabl
$ sudo make dkms-install

Now the module should be installed. To activate the nvidiabl module you should issue the command:

$ sudo modprobe nvidiabl

Now the directory /sys/class/backlight/nvidia_backlight/ should be present. In order to manually change the brightness you have to write in the brightness file:

$ sudo su
# echo 100 > /sys/class/backlight/nvidia_backligh/brightness

You can substitute 100 with any value up to 127. In my case not the complete range of backlight are supported. You can tune the brightness calibration by varying the min and max parameters (you will still have to write values in brightness up to 127):

$ sudo modprobe -r nvidiabl
$ sudo modprobe nvidiabl max=100000 min=10

You can load the module at startup by adding nvidiabl (with or without max and min parameters) to the file /etc/modules, but I still haven't figured out how to properly add hotkeys.

share|improve this question
    
What version of Ubuntu are you using? –  functionptr Dec 26 '12 at 4:29
    
@function It's 12.10 (I've also updated the question) –  pygabriel Dec 27 '12 at 2:52
    
Have you tried nvidiabl? I need this on my HP Elitebook in combination with a 313.x Nvidia driver for stable brightness controls. –  gertvdijk Dec 28 '12 at 12:41
    
@gertvdijk Thank you for the suggestion! I installed nvidia 313 driver and nvidiabl (I loaded with modprobe -r nvidiabl) but still not working –  pygabriel Dec 28 '12 at 20:56
1  
@gertvdijk I realized that the nvidiabl module added another sys (nvidia_backlight) interface. By acting on this interface the backlight of the monitor works! Thank you so much –  pygabriel Dec 30 '12 at 9:26

4 Answers 4

I dunno if this is helpful to anyone at all, but I've come across this post several times looking for help with my Y500.

I'm running mint cinnamon 17 and I have the GT 750M, with the NVIDIA drivers. All I needed to do was install xbacklight and set my keyboard bindings for the function keys to xbacklight -inc 10 and xbacklight -dec 10.

share|improve this answer

I am using xbacklight you can install it with: sudo apt-get install xbacklight xbacklight use-help for saver as used, is very simple to use, you can assign any key convinacion ami I worked until you install some nvidia driver you can install it manually by downloading the driver from the nvidia official website as follows: ctrl + alt + f1 LightDM stop sudo service sudo chmod + x NVIDIA.run sudo. / NVIDIA.run

if there is some error with the nouveau driver, select that whether or accept restart the computer and re-run the NVIDIA.run

or repositories THROUGH for ubuntu 13.04 or 12.10: sudo apt-add-repository ppa: xorg-edgers/ppa for ubuntu 12.04: sudo apt-add-repository ppa: ubuntu-x-swat/x-updates

sudo apt-get update sudo apt-get install nvidia-current nvidia-settings

share|improve this answer

Add this to grub:

acpi_backlight=vendor
share|improve this answer
    
Did you try this and did it work? –  Githlar May 5 '13 at 0:47

I installed Xubuntu 12.10 on my new Lenovo Y500 and also could not adjust brightness, it was at at maximum and could not be controlled. Get installed and used graphics driver:

lshw -c video

Gave me:

configuration: drigver=nouveau latency=0
  • changing the value in /sys/class/backlight/acpi_video0/brightness does not change brightness
  • booting with acpi_backlight=vendor does not change brightness
  • etpci -s 00:01.0 F4.B=XX (XX = 00 to ff) does not change brightness

For the moment I solved this by installing the nvidia driver:

sudo apt-get install linux-source
sudo apt-get install linux-headers-generic
sudo apt-get install nvidia-current-updates

This gives you the terminal command:

sudo nvidia-settings 

Go to: DFP-0-(LGD), Tab: Color Correction

Here you can set the brightness.

share|improve this answer
    
No. This is not changing the brightness of the backlight. It will change the output of colours and will result in a lower contrast and will not help in reducing power usage. –  gertvdijk Dec 28 '12 at 22:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.