Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to migrate from Windows to Ubuntu 12.04, dual-booting at the moment. One problem I am facing is the RAID controller, I'm not able to mount any of the drives connected to it. (The OS is up and running, installed on a separate HD not connected to the RAID controller.)

The raid controller is an Adaptec 5805 with a couple of HD, some of them are gpt (>2TB).

I have installed the Adaptec Storage Manager and I can view the all the HD and the RAID set-up. Looks like the Adaptec storage manager works fine from what I can tell.

The disks are visible in Nautilus with correct name. When I try to mount any I get the error code 12?

Error mounting: mount exited with exit code 12: Failed to read last sector (1953520001): Invalid argument
HINTS: Either the volume is a RAID/LDM but it wasn't setup yet,
   or it was not setup correctly (e.g. by not using mdadm --build ...),
   or a wrong device is tried to be mounted,
   or the partition table is corrupt (partition is smaller than NTFS),
   or the NTFS boot sector is corrupt (NTFS size is not valid).
Failed to mount '/dev/sdc1': Invalid argument
The device '/dev/sdc1' doesn't seem to have a valid NTFS.

Maybe the wrong device is used? Or the whole disk instead of a partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

I have not installed the driver from Adaptec as I supposed that's included in 12.04, correct or incorrect?

Any one else that already gone through this process or have any tips?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.