Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am a new Ubuntu user. I'm trying to install a package in a file called VNC-Viewer-5.0.3-Linux-x86.gz. I keep having problems.

The package is in my folder: /home/Downloads/VNC-Viewer-5.0.3-Linux-x86.gz

I tried:

owner@ubuntu:~$ cd ~/Downloads
owner@ubuntu:~/Downloads$ sudo apt-get install VNC-Viewer-5.0.3-linux-x86.gz
[sudo] password for owner: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package VNC-Viewer-5.0.3-linux-x86.gz
E: Couldn't find any package by regex 'VNC-Viewer-5.0.3-linux-x86.gz'

I also tried:

owner@ubuntu:~/Downloads$ ./configure
bash: ./configure: No such file or directory

I have followed sudo apt-get install build-essential checkinstall as explained on this wiki page and I am still quite lost in how to install this gz package. This package is needed to remotely control my school computer.

My Kernel is Linux-3.5.0-21 generic (x86-64)
Distribution Ubuntu 12.10
GNU C compiler version 4.7.2

share|improve this question
possible duplicate of How to install a .tar.gz (or .tar.bz2) file? – Jorge Castro Dec 25 '12 at 19:13
Not a compressed tarball (.tar.gz, .tar.bz2)? Then gunzip VNC-Viewer-5.0.3-linux-x86.gz – user8290 Dec 25 '12 at 19:28
Indeed, as @Christopher points out, this is not a duplicate of that question, and the answers by Christopher and by McNisse are quite appropriate. – Eliah Kagan Dec 25 '12 at 20:15
up vote 1 down vote accepted

A gz file is compressed with gzip, so just "un-gzip" a file with gunzip. For the binary download at, as a regular user:

mkdir -p ~/bin
cd ~/bin
mv ~/Downloads/VNC-Viewer-5.0.3-linux-x86.gz .
gunzip VNC-Viewer-5.0.3-linux-x86.gz
chmod +x VNC-Viewer-5.0.3-linux-x86

Then double-click it from a GUI file manager or start it from the command line:


If there was no bin directory to start, then the PATH will get updated when you log out and in again. After this it's just


from any directory. You could rename the file, too, if you like, or make symbolic link:

cd ~/bin
ln -s VNC-Viewer-5.0.3-linux-x86 vncv

Then call it with vncv or whichever name you pick for the symlink.

share|improve this answer
Hi. I really appreciate the help. But I run into some problems at the third step:owner@ubuntu:~$ mkdir -p ~/bin owner@ubuntu:~$ cd ~/bin owner@ubuntu:~/bin$ mv ~/Downloads/VNC-Viewer-5.0.3-linux-x86.gz mv: missing destination file operand after /home/owner/Downloads/VNC-Viewer-5.0.3-linux-x86.gz' Try mv --help' for more information. Am I missing some simple things? – user116727 Dec 26 '12 at 4:05
@user116727 Is the command missing the "dot" at the end of the command? It's mv source destination, so the "dot" is the destination, referring to the current directory, ~/bin. – user8290 Dec 26 '12 at 14:51
@user116727 They have a 64-bit binary download, too. – user8290 Dec 26 '12 at 15:19
Thanks so much! This is a really dumb question. I swear I put the file in the download folder. but when i re-run the code. it says owner@ubuntu:~/bin$ mv ~/Downloads/VNC-Viewer-5.0.3-linux-x86.gz . mv: cannot stat `/home/owner/Downloads/VNC-Viewer-5.0.3-linux-x86.gz': No such file or directory i'm really confused. i swear the folder is there... – user116727 Dec 26 '12 at 17:19
@user116727 If it really is in /home/owner/Downloads, maybe tab completion could help with typos? mv /home/owner/Downloads/VNC[TAB] /home/owner/bin. Or use a GUI file manager. – user8290 Dec 26 '12 at 17:28

The file that you have downloaded contains x86 in the name. This gives a hint that it contains a 32-bit binary, you should be able to make in run by installing a 32-bit runtime. But one cannot be sure before the file is unpacked.

Hovewer, before I go in to how you unpack the file. Have you tried any of the vnc viewers that exist in the package manager? xvnc4viewer, xtightvncviewer and some more. Start the package manager and search for vnc.

Now, back to your file. Unpack it with gunzip.

gunzip VNC-Viewer-5.0.3-linux-x86.gz

You should get a file named VNC-Viewer-5.0.3-linux-x86. You need to make it executable and then start it:

chmod +x VNC-Viewer-5.0.3-linux-x86

This might not work because you may not have 32-bit supporting libraries ("runtime") installed (or the archive contains something else). Check out this answer.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.