Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently bought a Lenovo thinkpad edge with Windows 8 preinstalled on it, and I installed Ubuntu 12.10

I mostly followed the instructions under 'General instructions' here: https://help.ubuntu.com/community/UEFI except I chose 'Something else' as an option when installing and then didn't create a new efi partition for Ubuntu, only one swap and one ext4 as root.

Problem: when I turn on the computer and it enters grub menu (i have grub2) these are the options:

  • Ubuntu;
  • Advanced options for ubuntu;
  • Windows 8 (loader) (on /dev/sda4);
  • System setup

and ubuntu starts up normally, but when I choose windows I get:

cannot find command 'drivemap';
invalid efi file path

However, when I alter the startup order in BIOS, options are: 1) Ubuntu, 2) Hard disk, 3) Windows 8 setup, so my hard drive, or Windows 8 setup be loaded first, Windows 8 starts up normally (without showing the grub menu)

I have found simmilar problems, and followed this instruction https://wiki.archlinux.org/index.php/GRUB2#Multiboot_in_BIOS

I found here Grub errors during UEFI dual boot for Windows 8 (can't find command 'drivemap') though I didn't directly edit the grub.cfg file, I edited 40_custom file in /etc/grub.d. I had some errors in writting though (they showed as I ran grub-mkconfig -o grub.cfg) so I didn't go through with it...

I shall appretiate any help. Mostly it concerns me that I cannot yet really pinpoint the problem.

share|improve this question
    
check out this link [Installing Ubuntu on a Pre-Installed Windows 8 system][^2] [^2]: askubuntu.com/questions/221835/… –  Mukund Dec 25 '12 at 16:17
    
for this solution I should delete the ubuntu and reinstall it the right way, as I get it. right? well, the problem there is, my windows 8 was preinstalled so I don't have a cd, and I understood that I need it to be able to boot win8 after I delete ubuntu- or am I wrong? and also, is there another way, like simply to reinstall ubuntu, on the partition where it now is (is that doable?)? –  loodista Dec 25 '12 at 21:32
    
yeah reinstall Ubuntu on the partition where it is now. Yes it is doable...when you are installing Ubuntu click on the option "something else" and then format the drive where you had installed Ubuntu and reinstall it on the same partition. –  Mukund Dec 26 '12 at 9:19
add comment

4 Answers

You could try installing my rEFInd boot manager to supplement or replace GRUB. Be aware, though, that the "boot repair" utility others have been recommending renames the Windows boot loader file in a standards-violating way, which means that rEFInd won't be able to locate the Windows boot loader. If you haven't run the boot repair tool, this shouldn't be an issue; but if you have, you'll have to rename what is, in Linux, /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi.bkp to /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi, overwriting the file that currently uses the second name (it's a duplicate of GRUB). If the former file doesn't exist, this isn't an issue.

share|improve this answer
add comment

You need to purge and reinstall GRUB this way:

  1. run Boot-Repair --> Advanced options
  2. go to the "GRUB options" tab, tick "Purge GRUB then reinstall it"
  3. click Apply

Indicate the new URL that will appear if any problem.

share|improve this answer
add comment

yeah reinstall Ubuntu on the partition where it is now. Yes it is doable...when you are installing Ubuntu click on the option "something else" and then format the drive where you had installed Ubuntu and reinstall it on the same partition.

share|improve this answer
add comment

Have you tried the solution given in After installing Ubuntu I can't boot Windows 8 anymore ? It says to disable SecureBoot and FastBoot in your BIOS and then run Boot-Repair.

share|improve this answer
    
I deactivated SecureBoot before allready, forgot to mention it. Don't know what FastBoot option is, didn't find it. I ran BootRepair from LiveCD ubuntu and it said there was an error of some kind (ubspecified), but it did do work - here is the pastebin: paste.ubuntu.com/1465556 still the same problem occurs –  loodista Dec 25 '12 at 21:26
    
**I forgot: the pastebin said: 'Please do not forget to make your BIOS boot on sda2/EFI/ubuntu/grubx64.efi file!' but there is no such entry in boot options, just 'ubuntu'. –  loodista Dec 25 '12 at 21:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.