Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.
I bought Epson L210 color printer and want to use it in Ubuntu 12.04.

when i connected that to PC, Ubuntu configured a default printer as L210 series, but it doesn't print! it just show message "printing completed" but nothing! How i can install and use this printer in Linux Ubuntu? I searched Internet, but no solution! what's your solution please help me. thank you

share|improve this question

3 Answers 3

up vote 2 down vote accepted

you can try to download at the link below:

share|improve this answer
aoo! it worked! thank you so much! – deniz Dec 31 '12 at 14:55

I am L210 users but i don't encounter a problem like that. Have you charge the ink before you proceed to print? you have to charge the ink for about 20min as follow to the instruction. The orange light will blink for 20 min and it will stood when the cartridge is finish to charge its ink. Hope it will help you.

share|improve this answer

for me printing worked but scanning did not. from Epson's site, downloaded and installed iscan-data_1.36.0-1_all.deb and iscan_2.30.1-1~usb0.1.ltdl7_amd64.deb - the iscan software works just fine.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.