Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying to turn off nvidia PowerMizer (that is set the performance level to 2 - max). I can do it with nvidia-settings, but it goes back to default after restart. Here's what I have tried:

  • nvidia-settings as root - saving settings to xorg.conf and ~/.nvidia-settings-rc
  • adding'options nvidia NVreg_RegistryDwords="PerfLevelSrc=0x2222"' to /etc/modprobe.d/nvidia.conf - nothing happened
  • adding Option "RegistryDwords" "PowerMizerLevel=0x2" "PowerMizerLevelAC=0x2" to xorg.conf under device section : gdm did not start up - had to delete xorg.conf to recover
  • adding Option "RegistryDwords" "PowerMizerEnable=0x0" to xorg.conf : nothing happened

Any idea how I can do this?

P.S. Ubuntu 12.10

share|improve this question

2 Answers 2

up vote 7 down vote accepted

You need to remove whatever you've added to xorg.conf, and add something like the following:

Section "Device"
  Identifier "NVIDIA GeForce"
  Driver     "nvidia"
  Option     "RegistryDwords" "PerfLevelSrc=0x3322; PowerMizerDefaultAC=0x1"
EndSection

PerfLevelSrc=0x3322 means it's going to use fixed PowerMizer mode when on AC.

PowerMizerDefaultAC=0x1 defines the power mode, with 0x1 being Maximum performance.

There is no need to reboot, just logout/login.

share|improve this answer
3  
Still goes back to "adaptive" –  lfk Dec 25 '12 at 12:57
    
Make sure the PowerMizer is enabled in the Nvidia Settings. If that still doesn't work, you might want to try PerfLevelSrc=0x2222 instead of PerfLevelSrc=0x3322. –  mikewhatever Dec 25 '12 at 13:14
    
Makes no difference. I enabled PowerMizer in nvidia settings and added the line to xorg.conf (tried both). Still once I log back in it is back to 'adaptive' in nvidia settings –  lfk Dec 25 '12 at 13:25
    
You are right, I forgot the "RegistryDwords" part. The above code has been corrected and tested, and should work. Let me know if it doesn't. –  mikewhatever Dec 25 '12 at 14:17
1  
It worked! Thanks! The drop-down menu in nvidia settings is still on adaptive, but the performance level stays on 2 and doesn't change which means the code is working –  lfk Dec 25 '12 at 14:25

There is an unofficial patch for recent versions of the proprietary NVIDIA graphics driver (334.21 and 337.12) that writes GPU target attributes like GPUPowerMizerMode to the configuration file of nvidia-settings. That means you can use the NVIDIA X Server Settings GUI to permanently set your desired performance level just as it should be.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.