Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yes, I've looked at several other posts, and other sites trying to figure out what's up, but I've followed the steps, and had no success.

Note that I'm a relative newbie to setting up wireless on Ubuntu, so please feel free to suggest dumb errors like "is it on", I very likely missed something fundamental.

Output from a couple of commands:

$ lspci | grep

0c:00.0 Network controller: Broadcom Corporation BCM4311 802.11a/b/g (rev 01)

$ iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

Additional Drivers says "Using Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source (proprietary)"

I've tried

sudo apt-get install bcmwl-kernel-source

It just gives errors:

sudo apt-get install bcmwl-kernel-source Reading package lists... Done Building dependency tree Reading state information... Done The following NEW packages will be installed: bcmwl-kernel-source 0 upgraded, 1 newly installed, 0 to remove and 129 not upgraded. Need to get 0 B/1,150 kB of archives. After this operation, 3,120 kB of additional disk space will be used. Selecting previously unselected package bcmwl-kernel-source. (Reading database ... 204100 files and directories currently installed.) Unpacking bcmwl-kernel-source (from .../bcmwl-kernel-source_5.100.82.112+bdcom-0ubuntu3_i386.deb) ... Setting up bcmwl-kernel-source (5.100.82.112+bdcom-0ubuntu3) ... Loading new bcmwl-5.100.82.112+bdcom DKMS files... Building only for 3.5.0-18-generic Building for architecture i686 Building initial module for 3.5.0-18-generic Done.

wl: Running module version sanity check. - Original module - No original module exists within this kernel - Installation - Installing to /lib/modules/3.5.0-18-generic/updates/dkms/

depmod....

DKMS: install completed. ERROR: Module b43 does not exist in /proc/modules ERROR: Module b43legacy does not exist in /proc/modules ERROR: Module ssb does not exist in /proc/modules ERROR: Module bcm43xx does not exist in /proc/modules ERROR: Module brcm80211 does not exist in /proc/modules ERROR: Module brcmfmac does not exist in /proc/modules ERROR: Module brcmsmac does not exist in /proc/modules ERROR: Module bcma does not exist in /proc/modules update-initramfs: deferring update (trigger activated) Processing triggers for initramfs-tools ... update-initramfs: Generating /boot/initrd.img-3.5.0-18-generic

also, more output

sudo lshw -C network *-network UNCLAIMED
description: Network controller product: BCM4311 802.11a/b/g vendor: Broadcom Corporation physical id: 0 bus info: pci@0000:0c:00.0 version: 01 width: 32 bits clock: 33MHz capabilities: pm msi pciexpress bus_master cap_list configuration: latency=0 resources: memory:fe8fc000-fe8fffff *-network description: Ethernet interface product: NetXtreme BCM5755M Gigabit Ethernet PCI Express vendor: Broadcom Corporation physical id: 0 bus info: pci@0000:09:00.0 logical name: eth0 version: 02 serial: 00:1c:23:5b:29:73 size: 100Mbit/s capacity: 1Gbit/s width: 64 bits clock: 33MHz capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.123 duplex=full firmware=5755m-v3.29 ip=192.168.1.69 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s resources: irq:45 memory:fe7f0000-fe7fffff

Any ideas?

sorry about the formatting getting messed up on the quotes

share|improve this question
add comment

1 Answer 1

With the Ubuntu 11.x releases, the proprietary Broadcom drivers stopped working with the 4311 Broadcom chips (see bug 732677). However these chips works fine with the open b43 driver, but you first need to install their firmware -- easily done with a package install. First, remove the proprietary STA driver if installed, (which is the same as driver wl), and its configuration files which suppress the working b43 driver) by reversing whatever you did to install them:

   sudo apt-get purge bcmwl-kernel-source 

and/or run additional-drivers and unselect the Broadcom STA driver

Check that your removal/deactivation above is complete:
all the lines with "blacklist b43" should have been removed from all files in /etc/modprobe.d. These blacklist lines suppress the b43 driver, so they must be removed -- just the exact "b43" and "b43legacy" lines, leave the "bcm43xx" lines alone. Deal with any leftovers:

sudo rm /etc/modprobe.d/blacklist-bcm43.conf

 gksudo gedit  any-file-found-with-b43

and delete or put a # at the beginning.

The proprietary firmware cannot be distributed with the release,so you have to manually add it. Use a wired connection, and in a terminal:

   sudo apt-get install linux-firmware-nonfree

Another source of the Broadcom firmware is the package firmware-b43-installer

   sudo apt-get install firmware-b43-installer  

but only one set of firmware is needed (and non-4311 users should check for needing other versions of the firmware (like firmware-b43-lpphy-installer).

With the firmware in place, NetworkManager may start scanning, if not, manually load the b43 driver module, or just reboot.

 sudo modprobe b43  

At this point, you should have the b43 driver module loaded, and the wl and another possible driver, brcma module NOT present in the module list produced by:

 sudo lsmod | sort

If the brcma module is listed, blacklist it by adding the following: blacklist brcma blacklist brcmsmac blacklist brcm80211 to file /etc/modprobe.d/blacklist.conf

  gksudo gedit /etc/modprobe.d/blacklist.conf

NetworkManager should start scanning and offer a list of possible connection points within a few seconds.

Select your access point, select the correct encryption method, and enter your key. If you are not broadcasting your ssid and it does not show up in the list of access points, you might have to left click NetworkManager and select the menu item "connect to hidden network", and enter your ssid. Next boot, the connection should be automatic.

share|improve this answer
    
Thanks for the help, but I'm not there yet. `sudo lsmod | sort –  Tom Dec 25 '12 at 17:19
    
The bcma has to go also. That's a newer driver which might or might not work -- don't know much about it. –  ubfan1 Dec 25 '12 at 17:22
    
do I add it to /etc/modprobe.d/blacklist.conf? add a line of 'blacklist bcma'? Then is a reboot necessary? (I'll try all of this, just getting the steps down) –  Tom Dec 25 '12 at 17:25
    
Yes, That should do it, so b43 is the only wireless driver left in the lsmod listing. –  ubfan1 Dec 25 '12 at 17:34
    
Still no luck. lspci shows 0c:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11a/b/g [14e4:4312] (rev 01) Subsystem: Dell Wireless 1490 Dual Band WLAN Mini-Card [1028:0007] Kernel driver in use: b43-pci-bridge I added the following to /etc/modprobe.d/blacklist.conf blacklist brcma blacklist brcmsmac blacklist brcm80211 blacklist bcma –  Tom Dec 25 '12 at 17:41
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.