Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I ran lspci | grep Audio and got:

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

I've searched the forums and added the following line to alsa.conf

# macbook air sound
options snd-hda-intel model=mbp3

I rebooted and there was still no sound.

So I ran alsamixer. It shows that the speakers and master are not muted. The speakers and microphone are still not working. What can I do to get them to work? I'm running a single-boot Ubuntu 12.10 system with a 64-bit kernel, on a Macbook Air 1.1.

I also ran the command hwinfo and got the following results

'hwinfo --sound

hal.1: read hal dataprocess 2630: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file ../../dbus/dbus-errors.c line 282. This is normally a bug in some application using the D-Bus library. libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files 13: PCI 1b.0: 0403 Audio device
[Created at pci.318] Unique ID: u1Nb.4u0CAOk3K5C SysFS ID: /devices/pci0000:00/0000:00:1b.0 SysFS BusID: 0000:00:1b.0 Hardware Class: sound Model: "Intel 82801H (ICH8 Family) HD Audio Controller" Vendor: pci 0x8086 "Intel Corporation" Device: pci 0x284b "82801H (ICH8 Family) HD Audio Controller" SubVendor: pci 0x106b "Apple Computer Inc." SubDevice: pci 0x00a2 Revision: 0x03 Driver: "snd_hda_intel" Driver Modules: "snd_hda_intel" Memory Range: 0x90500000-0x90503fff (rw,non-prefetchable) IRQ: 43 (338 events) Module Alias: "pci:v00008086d0000284Bsv0000106Bsd000000A2bc04sc03i00" Driver Info #0: Driver Status: snd_hda_intel is active Driver Activation Cmd: "modprobe snd_hda_intel" Config Status: cfg=new, avail=yes, need=no, active=unknown'

share|improve this question
    
The same problem persists in Ubuntu 13.04 (Raring) and Macbook Air 1,1. Furthermore, a bug has been filed for a similar issue with the Macbook Air 2,1 here: bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1181828 –  Treepata Sep 8 '13 at 22:45
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.