Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

When I'm going into a virtual terminal my Vim color scheme is ignored.

I've configured it by following this blog.

Heres all of my ~/.vimrc

if $COLORTERM == 'gnome-terminal'
    set term=gnome-256color
    set t_Co=256
    colorscheme railscasts
    colorscheme default

"FileType support
set filetype=on
filetype plugin on
filetype indent on

"Color scheme and font
autocmd FileType javascript,html,css,php colorscheme railscasts
autocmd FileType javascript,html,css,php set gfn=Monaco\ 10

autocmd FileType javascript,html,css,php set ai
autocmd FileType javascript,html,css,php set sw=4
autocmd FileType javascript,html,css,php set ts=4
autocmd FileType javascript,html,css,php set sts=4
autocmd FileType javascript,css,php set textwidth=79

"Enable autocompletion
autocmd FileType javascript set omnifunc=javascriptcomplete#CompleteJS
autocmd FileType html set omnifunc=htmlcomplete#CompleteTags
autocmd FileType css set omnifunc=csscomplete#CompleteCSS

"Enable line numbers
autocmd FileType javascript,css,php set number

"Enable incremental search
autocmd FileType javascript,html,css,php set incsearch

This part should have been fixed it right?

if $COLORTERM == 'gnome-terminal'
    set term=gnome-256color
    set t_Co=256
    colorscheme railscasts
    colorscheme default
share|improve this question

1 Answer 1

up vote 2 down vote accepted

It can be done but it quite complicated (so I recommend using a regular terminal if you really want the colors) but if you really want to do it have a look at the following question on superuser:

They instruct to set the appropriate TERM variable, this TERM variable then also needs to be added to your vimrc, becaues now the colors are only set for TERM=gnome-terminal.

share|improve this answer
What's up with these 256 limitations? Can't I just have 32bit or 64bit color???? I mean, dude, it's 2013, why aren't all terminals 32bit colored by now?! – trusktr Apr 5 '13 at 2:14

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.