Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I had problems with fglrx cause I have an ATI card, if I install the privative drivers from the Ubuntu repo, I get no Unity launch bar cause the drivers are not compatible with the new Xorg.

So, I installed manually the new beta drivers following the reponse of ryanpcmcquen in this question: Can't install ATI proprietary drivers in 12.10

Because I have also a 5670 card.

Everything work, I get now from info:

jdsampayo@jdsampayo-M61PME-S2:~$ fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 5670
OpenGL version string: 4.2.11995 Compatibility Profile Context

The problem is that when Unity starts I don't get any icons in desktop and right mouse clicks there also do nothing, but I get the Unity bar working.

If I launch ccsm and I disable the Unity plugin (bar dissapears) and reenable it, the bar reappears and icons in desktop and right click mouse in desktop works as expected.

Is there any way to do this automatically? (disable and enable Unity plugin)

Because I must do this each login to make the desktop work.

PD. I tried to put this info in the question I refer, but I have no reputation in askubuntu and couldn't find a way to add any info or comments in questions.

share|improve this question
    
This happened to me, and I managed to install fglrx-updates. That worked as expected. –  10robinho Dec 29 '12 at 22:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.