Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is there a way in Thunar (within XFCE) to disable displaying of Video thumbnails only and still allow Picture thumbnails?

I found this thread: Show me only picture thumbnails

But that is for Nautilus and I cannot find Thunar in that list anywhere. Or preferrably only remote videos, Nautilus used to only thumbnail local videos not remote. So if disabling for only remote is possible that would be better.

share|improve this question

2 Answers 2

up vote 4 down vote accepted

There is also now an officially recommended way to manage which thumbnails are generated in Thunar by tumbler, the Xfce thumbnailing service. Using the method described below means nothing will need to be uninstalled from the gstreamer set of packages, and all other thumbnails (apart from video) will be generated.

However, it is important to note that this is only possible if you have tumbler 0.1.27, although this will be at least the version in Raring (13.04). If you are on Xubuntu 12.10, you only need to enable the Xfce 4.12 ppa to get the latest version of tumbler.

On the Xfce announce mailing lists for January 2013, it was noted that, regarding tumbler 0.1.27,

This release ships a config file installed in the xdg directory to control the various plugins (especially the priority). There is also a cover download plugin (dependency is libcurl), but this has been disabled by default.

How to enable and disable various plugins is explained on the Xfce official page, but briefly here's how it works. As noted in the explanation, if you want to customise the tumbler rc file, you can make a tumbler folder in ~/.config and then copy tumbler.rc from /etc/xdg/tumbler to that folder. The easiest way to do it is to use these commands from the xfce documentation:

mkdir -p $XDG_CONFIG_HOME/tumbler
cp /etc/xdg/tumbler/tumbler.rc $XDG_CONFIG_HOME/tumbler/

Now, edit the file with

gedit ~/.config/tumbler/tumbler.rc

and you will see something like this sample rc file, which has sections for video, image and other thumbnailer plugins.

As an example, you could find the section Video Thumbnailers in the file above and set Disabled=true in the sections for the ffmpegthumbnailer and the gstreamer plugins. Using this method you do not have to remove gstreamer0.10-plugins to stop video thumbnails being shown.

Excerpt from the Video Thumbnailers section of tumbler.rc:

# ffmpegthumbnailer plugin
[FfmegThumbnailer]
Disabled=true
Priority=2
Locations=
MaxFileSize=0

# GStreamer plugin
[GstThumbnailer]
Disabled=true
Priority=1
Locations=
MaxFileSize=0

If at some later point you find that you do not want to entirely disable the video plugins, you could instead use Disabled=false to re-enable them and set a value for the MaxFileSize, so that only files up to a certain size were shown. This would solve problems with high memory usage when thumbnails for very large files are being generated.

  • Note: after making any changes to tumbler.rc , it is crucial that you log out and log in again. Video thumbnailing for those two plugins, for example, would not be disabled until you logged in again.

  • Remember, this will only work if you have tumbler 0.1.27 or a later version installed.

share|improve this answer

open your synaptic package manager and remove gstreamer0.10-plugins and ffmpegthumbnailer packages . I am not sure which packages installation causes this problem to you but Thumbnail generation will done due to because of this two packages only .

so remove the one which is installed in your system and synaptic is the easy way .

hope that helps .

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.