Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently migrated from a windows 7 PC to Ubuntu 12.10 64Bit.

Ubuntu Experience Level: NewBee.

Recommended/Restricted updates installed. I've added an NVIDIA Binary Driver for my Display.

The hardware build is,

Intel Core2Duo E8400 3.0GHz

Intel DP35DP Mobo with ONBoard LAN

2 GB DDR2 Memory

NVIDIA 8600 GT Display Adapter.

I have the Ubuntu 12.10 installed on an 8GB flash drive(USB2.0). Also happy with general system performance with seamless HD video playback. The file tranfer speeds and download speeds are satisfactory and is par to my previous Windows 7 performances.

The Internet browsing experience is weird and slow. Most sites are loading very slowly and some aren't loading at all. I've tried things on Firefox 17, Opera 12.11 and Chromium 22.0.1, but issue persists. The Opera lets me load some sites with turbo enabled.

The flash streaming is fine with youtube but vimeo videos aren't loading. Common sites like yahoo.com and hotmail aren't loading at all on Firefox and Chromium. Opera with turbo enabled works at times.It even loads flickr.com thread page with turbo enabled.

nload at fair traffic times return,

Incoming:

Curr: 208.39 KBit/s

Avg: 93.45 KBit/s

Min: 0.00 Bit/s

Max: 756.08 KBit/s

Ttl:7.45 MByte

Outgoing:

Curr: 11.43 KBit/s

Avg: 13.39 KBit/s

Min: 0.00 Bit/s

Max: 131.33 KBit/s

Ttl:1.25 MByte

At the same time my System Load Indicator 3.0 Applet returns, Downspeed 60 Kbps

Mine is a Wired DSL @512Mbps connection(ISP:BSNL,India).

The IPv6 tests are giving me a green signal.

I've done a lot of searches on many forums but wasn't able to get a working solution. Even tried disabling IPv6 on firefox config.

Here is the ethtool result:

ethtool -i eth0

driver: e1000e

version: 2.0.0-k

firmware-version: 1.3-0

bus-info: 0000:00:19.0

supports-statistics: yes

supports-test: yes

supports-eeprom-access: yes

supports-register-dump: yes

supports-priv-flags: no

Ethernet Controller Details:

~$ lspci -nn | grep -i 'Ethernet Controller'

00:19.0 Ethernet controller [0200]: Intel Corporation 82566DC-2 Gigabit Network

Connection [8086:294c] (rev 02)

How can get my Internet to run at optimal speeds ?

share|improve this question
    
i've added that my connection is an DSL.The connection settings was IPv4 automatic with a PPPusername and PPPpassword.No additional PPoE config was done. –  Sivan Dec 25 '12 at 10:05
    
I noticed that my router was illconfigured.Thanks to link.I configured my router and now the network is performing at optimal speeds.The glitch with certain sites(mentioned in post) are resolved. –  Sivan Dec 25 '12 at 10:33
    
If you found a solution for your question consider adding it in as a full answer so others may learn from it. –  Wolfer Oct 13 '13 at 7:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.