Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've added the Qt5 Daily repository, installed the qt5-meta-full and added /opt/qt5/bin/qmake to Qt Versions. Now I get

:-1: error: Unknown module(s) in QT: declarative

Is it possible yet to use Qt5 with Qt Creator?

share|improve this question
1  
"apt-get install qtquick1-5-dev" makes that specific build error go away, I think –  Erik Sjölund Apr 29 '13 at 17:20
    
Thanks Erik, that helped me since I got the same error above. (Missing Qt Declarative.) –  jeremiah Nov 26 '13 at 13:36
add comment

1 Answer

up vote 2 down vote accepted

Yes, but not the version of Qt Creator in the archives. Qt 5.0 is compatible only with Qt Creator 2.6.1+. Thankfully, installing Qt Creator 2.6.1 is relatively easy:

  1. Remove the existing version of Qt Creator you have installed:

    sudo apt-get autoremove qtcreator
    
  2. Download the appropriate installer from this page:

  3. cd into the directory that contains the installer you downloaded and run:

    chmod 755 qt-creator-linux-*-opensource-2.6.1.bin
    
  4. Launch the installer:

    sudo ./qt-creator-linux-*-opensource-2.6.1.bin
    
  5. Complete the installer, leaving all settings at their defaults.

If all goes well, you should end up with an icon in your desktop environment's dash or equivalent. You should then be able to use Qt 5.0 with Qt Creator.

share|improve this answer
    
Strangely, I still had Qt Creator 2.4 in Dash after this. But running bin/qtcreator from the installation directory launches 2.6.1. Checking it. –  int_ua Dec 27 '12 at 19:52
    
Looks like ok. I wanted Qt Quick 2.0 and it's not installed. But that's another question. Do you know if that's available? –  int_ua Dec 27 '12 at 19:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.